DRb does not activate using options file

Hello List,

For a small project I’ve been using ‘ruby script/spec -X spec’ to
execute my specs.

Now that I added ZenTest on it, found that the test takes longer to
run due the complete load of test environment.

Since autotest uses ‘script/spec -O spec/spec.opts’ as the command, I
decided to add --drb to spec.opts

Using --drb or -X, spec_server is just ignored and environment get
loaded locally.

Trying to pinpoint the problem, it seems that using -O don’t
handle/load set --drb, but when you put all the options in the command
line, works as expected.

Couldn’t find anything besides this
(rspec/lib/spec/runner/option_parser.rb:111)

on(*OPTIONS[:drb]) {}

==

Maybe I’m missing something, did anyone get it working?

Thanks in advance,

Luis L.
Multimedia systems

A common mistake that people make when trying to design
something completely foolproof is to underestimate
the ingenuity of complete fools.
Douglas Adams

On Jan 30, 2008 7:43 PM, Luis L. [email protected] wrote:

something completely foolproof is to underestimate
the ingenuity of complete fools.
Douglas Adams


rspec-users mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/rspec-users

I’m also having this problem where --drb isn’t being picked up.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs