Downgrade rails 3.1 project from ruby 1.9.2 to 1.8.7

Hey this may be a dumb question but I am attempting to downgrade my ruby
version to 1.8.7 for my rails 3.1 project, since that is the version
supported by my hosting solution. I have uninstalled 1.9.2 and
installed ruby 1.8.7 on my dev machine and when I ran bundle install and
my gems installed just fine. But when I tried to run ‘rails server’ I
got some funny errors:

Invalid gemspec in
[C:/Ruby187/lib/ruby/gems/1.8/specifications/execjs-1.2.4.gemspec]:
invalid date format in specification: “2011-08-03 00:00:00.000000000Z”
Invalid gemspec in
[C:/Ruby187/lib/ruby/gems/1.8/specifications/rack-cache-1.0.3.gemspec]:
invalid date format in specification: “2011-08-27 00:00:00.000000000Z”
Invalid gemspec in
[C:/Ruby187/lib/ruby/gems/1.8/specifications/tilt-1.3.3.gemspec]:
invalid date format in specification: “2011-08-25 00:00:00.000000000Z”
Invalid gemspec in
[C:/Ruby187/lib/ruby/gems/1.8/specifications/execjs-1.2.4.gemspec]:
invalid date format in specification: “2011-08-03 00:00:00.000000000Z”
Invalid gemspec in
[C:/Ruby187/lib/ruby/gems/1.8/specifications/rack-cache-1.0.3.gemspec]:
invalid date format in specification: “2011-08-27 00:00:00.000000000Z”
Invalid gemspec in
[C:/Ruby187/lib/ruby/gems/1.8/specifications/tilt-1.3.3.gemspec]:
invalid date format in specification: “2011-08-25 00:00:00.000000000Z”
Invalid gemspec in
[C:/Ruby187/lib/ruby/gems/1.8/specifications/execjs-1.2.4.gemspec]:
invalid date format in specification: “2011-08-03 00:00:00.000000000Z”
Invalid gemspec in
[C:/Ruby187/lib/ruby/gems/1.8/specifications/rack-cache-1.0.3.gemspec]:
invalid date format in specification: “2011-08-27 00:00:00.000000000Z”
Invalid gemspec in
[C:/Ruby187/lib/ruby/gems/1.8/specifications/tilt-1.3.3.gemspec]:
invalid date format in specification: “2011-08-25 00:00:00.000000000Z”
←[31mCould not find rack-cache-1.0.3 in any of the sources←[0m
←[33mRun bundle install to install missing gems.←[0m

I just went through all the steps to install 1.8.7 and ‘gem install
rails’ to get everything in order, and it looked like it installed
rack-cache just fine

‘Successfully installed rack-cache-1.0.3’

If anyone has any tips on how to clean this up and successfully
downgrade my ruby version I would greatly appreciate it!

Thanks!

On Oct 4, 2011, at 8:08 AM, Daniel Nachbar wrote:

On Oct 4, 12:38 am, “Garrett S.” [email protected] wrote:

If anyone has any tips on how to clean this up and successfully
downgrade my ruby version I would greatly appreciate it!

I think you want to use RVM - http://beginrescueend.com/

+1, but doesn’t 3.1 require 1.9.2 or better? I could swear that’s a
given.

Walter

On Oct 4, 12:38am, “Garrett S.” [email protected] wrote:

If anyone has any tips on how to clean this up and successfully
downgrade my ruby version I would greatly appreciate it!

I think you want to use RVM - http://beginrescueend.com/

Dan N.

On 4 October 2011 15:22, Garrett S. [email protected] wrote:

+1, but doesn’t 3.1 require 1.9.2 or better? I could swear that’s a
given.

Is Rails 3.1 only available on 1.9.2? I was going by this:
http://guides.rubyonrails.org/getting_started.html
which says it only requires 1.8.7 or higher, but to avoid a couple 1.8.7
versions because they don’t work.

I think I saw that an upcoming version of rails will require 1.9.2 but
up till then 1.8.7 is fine.

Colin

+1, but doesn’t 3.1 require 1.9.2 or better? I could swear that’s a
given.

Is Rails 3.1 only available on 1.9.2? I was going by this:
http://guides.rubyonrails.org/getting_started.html
which says it only requires 1.8.7 or higher, but to avoid a couple 1.8.7
versions because they don’t work.

I think you want to use RVM - http://beginrescueend.com/

So if I use rvm or pik (on windows: https://github.com/vertiginous/pik/)
that should clear up those problems?

On Oct 4, 11:30am, “Garrett S.” [email protected] wrote:

I think you want to use RVM -http://beginrescueend.com/

So if I use rvm or pik (on windows:https://github.com/vertiginous/pik/)
that should clear up those problems?

Sorry, yes pik for Windows. I assume pik works comparably.
(I know almost nothing about Windows.)

From what you’ve sent (and the fact that I am not a
windows guy) it’s a little hard for me to guess how deep a
hole you are in and consequently if starting with RVM/pik
now will fix what all that is broken.

My point is more that having RVM/pik in place eliminates
the need to uninstall/reinstall in order to dynamically
switch versions.

So, if I were in your shoes, I’d set up RVM/pik then install
ruby 1.8.7 (and ruby 1.9.2 if you wish) and rails 3.1,
and try again.

Dan N.

Qualify this with : I am a ruby and rails newbie so for what it’s worth:

I recently started the rails journey and was working in windows using
cygwin
etc… I switched to ubuntu and originally was trying to make ruby
1.8.7
work with 3.1.0 and it just wasn’t happening… can’t remember the
details
of the problems I was having but they were numerous…

I switched to 1.9.2 and rails 3.1.0 and it’s been pretty smooth sailing
since… still haven’t gotten great results in windows but haven’t spent
much time trying since I got ubuntu working and solid. I do have a
friend
who works in windows (not sure if he does just ruby or does rails too
though)… but he uses mingw which I set up and did feel better
about…

Fwiw…

Max

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs