Dos problemas con in_place_editor_field

Hola,

tengo dos problemas con in_place_editor_field. A ver si alguien tiene
experiencia con situaciones parecidas:

a) Si tengo un trozo de código como


<% if @user && @user.is_admin? %>
<%= in_place_editor_field :doc, :body, {}, {:rows => 35, :cols => 100}
%>
<% else %>
<%= markdown(@doc.body) %>
<% end %>

El usuario administrador no llegará a ver el @doc.body parseado por
markdown. ¿Existe alguna forma de aplicar algún tipo de filtro al
método del objeto llamado por el editor?

b) El segundo problema es más grave: al editar un texto marcado como
HTML con el editor-in-place, parece que “pierde” algunas etiquetas, en
concreto

(no todos) y

(todos)
En base de datos se guardan correctamente si existen en el texto
enviado, pero al hacer click sobre el texto y convertirse éste en
textarea, se pierden. Muy desconcertante. ¿Le suena a alguien este
tipo de bug?

Gracias por adelantado


Manuel
http://linkja.com * un agregador de tendencias
http://simplelogica.net
http://simplelogica.net/logicola

b) El segundo problema es más grave: al editar un texto marcado como
HTML con el editor-in-place, parece que “pierde” algunas etiquetas, en
concreto

(no todos) y

(todos)
En base de datos se guardan correctamente si existen en el texto
enviado, pero al hacer click sobre el texto y convertirse éste en
textarea, se pierden. Muy desconcertante. ¿Le suena a alguien este
tipo de bug?

Efectivamente. script.aculo.us quita los

de la respuesta Ajax. Bug
#3729

http://dev.rubyonrails.org/attachment/ticket/3729/load_text_url_stripping_html_tags_patch.diff


Manuel
http://linkja.com * un agregador de tendencias
http://simplelogica.net
http://simplelogica.net/logicola

On 1/16/07, Manuel González Noriega [email protected]
wrote:

b) El segundo problema es más grave: al editar un texto marcado como
HTML con el editor-in-place, parece que “pierde” algunas etiquetas, en
concreto

(no todos) y

(todos)
En base de datos se guardan correctamente si existen en el texto
enviado, pero al hacer click sobre el texto y convertirse éste en
textarea, se pierden. Muy desconcertante. ¿Le suena a alguien este
tipo de bug?

Siempre me resultaron problemáticos este tipo de editores.

Como sugerencia y también para escuchar tu opinión, no sería mejor
utilizar Markdown o Textile? Digo, además, la salida de éstos siempre
es (X)HTML estándar, bien formado, etc.

On 17/01/07, Damian J. [email protected] wrote:

Como sugerencia y también para escuchar tu opinión, no sería mejor
utilizar Markdown o Textile? Digo, además, la salida de éstos siempre
es (X)HTML estándar, bien formado, etc.

Hola Damián,

creo que estás confundiendo el in-place-editor con un editor wyswyg.
No es tal cosa, es solo que al pinchar sobre un texto, éste sea
remplazado por un formulario con un textarea para el texto y un
botónde enviar, para poder editar ese texto sobre la marcha. Es el
comportamiento por ejemplo de Flickr con los títulos y descripciones
de las fotos, si lo conoces.

Por tanto esto no indica nada sobre el formato del texto. A mi me
gusta Markdown y de hecho se utiliza en casi todos los textos de la
aplicación de la que hablo. Pero hay una página que algo es
máscomplicada y necesita HTML (aunque válido y estructural, por supuesto
:slight_smile:

De todas formas, no sé si ayer llegué a enviar a la lista la
soluciónal segundo problema. Es un bug registrado de script.aculo.us, que
elimina las etiquetas HTML de los textos sin que haya necesidad. Se
soluciona retocando una línea en public/javascripts/controls.js

http://dev.rubyonrails.org/ticket/3729

Manuel
http://linkja.com * un agregador de tendencias
http://simplelogica.net
http://simplelogica.net/logicola

On 1/17/07, Manuel González Noriega [email protected]
wrote:

creo que estás confundiendo el in-place-editor con un editor wyswyg.
No es tal cosa, es solo que al pinchar sobre un texto, éste sea
remplazado por un formulario con un textarea para el texto y un botón
de enviar, para poder editar ese texto sobre la marcha. Es el
comportamiento por ejemplo de Flickr con los títulos y descripciones
de las fotos, si lo conoces.

Ja! qué burrada la mía… :slight_smile:

Gracias por el dato, lo voy a probar en estos días :slight_smile:

Un saludo!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs