Don't know what this error means

Any idea what this error means?

=> Booting WEBrick…
C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.12.5/lib/action_controller/routing.rb:651:in
method_missing': undefined methodresources’ for
#ActionController::Routing::RouteSet:0x344769c (NoMethodError)
from ./script/…/config/…/config/routes.rb:4
from
C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.12.5/lib/action_controller/routing.rb:625:in
draw' from ./script/../config/../config/routes.rb:1 from C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140:inload’
from
C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140:in
load' from C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.12.5/lib/action_controller/routing.rb:608:inreload’
from
C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:239:in
initialize_routing' from C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:105:inprocess’
… 13 levels…
from
C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
require' from ./script/server:3 from -e:4:inload’
from -e:4

On 2/12/07, David S. [email protected] wrote:

from
/lib/active_support/dependencies.rb:140:in
C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6
/lib/initializer.rb:105:in
process' ... 13 levels... from C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1 /lib/active_support/dependencies.rb:147:inrequire’
from ./script/server:3
from -e:4:in `load’
from -e:4

Can you post The first 4 lines of your routes.rb file please. Also what
version of rails are you using?

On Feb 11, 2007, at 9:41 PM, Daniel N wrote:

from
1.3.1/lib/active_support/dependencies.rb:140:in
C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/

Can you post The first 4 lines of your routes.rb file please. Also
what version of rails are you using?

It’s clearly Rails 1.1.6 and I suspect that from the other gems, that
it’s not the 1.2RC1 either.

If that’s the case, then you appear to be using RESTful routes which
were introduced with 1.2. If you can upgrade your Rails to 1.2.x,
you should be able to use this feature.

-Rob

Rob B. http://agileconsultingllc.com
[email protected]

On 2/12/07, Rob B. [email protected] wrote:

/lib/action_controller/routing.rb:651:in
/lib/active_support/dependencies.rb:140:in
C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails- 1.1.6
`require’
not the 1.2RC1 either.

If that’s the case, then you appear to be using RESTful routes which were
introduced with 1.2. If you can upgrade your Rails to 1.2.x, you should
be able to use this feature.

-Rob

Rob B. http://agileconsultingllc.com
[email protected]

That was what I was trying to get to, guess I should have looked further
down the stack trace…

Daniel ----- wrote:

On 2/12/07, David S. [email protected] wrote:

from
/lib/active_support/dependencies.rb:140:in
C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6
/lib/initializer.rb:105:in
process' ... 13 levels... from C:/David/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1 /lib/active_support/dependencies.rb:147:inrequire’
from ./script/server:3
from -e:4:in `load’
from -e:4

Can you post The first 4 lines of your routes.rb file please. Also what
version of rails are you using?

ActionController::Routing::Routes.draw do |map|

A resource for each post type

map.resources :messages, :plans, :documents, :projects, :contacts,
:member => { :download => :get }

Rails 1.1.6 I am using InstantRails though.

On 2/12/07, David S. [email protected] wrote:

from

ActionController::Routing::Routes.draw do |map|

A resource for each post type

map.resources :messages, :plans, :documents, :projects, :contacts,
:member => { :download => :get }

Rails 1.1.6 I am using InstantRails though.

As Rob said, the RESTful stuff didn’t get added to rails until R1.2 You
need to update your rails. I don’t have experience with instant rails,
but
perhaps use the rake task to freeze rails to a paricular version.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs