Don't know how to build task 'add_new_scripts'


#1

Looking at my changelog, it appears I’m using Rails 0.14.2, so I tried
to upgrade by doing:

$ rake update_javascripts
(in /var/www/html/rails)
$ rake add_new_scripts
(in /var/www/html/rails)
rake aborted!
Don’t know how to build task ‘add_new_scripts’

Any help?

thanks
csn


Yahoo! Mail - PC Magazine Editors’ Choice 2005
http://mail.yahoo.com


#2

I ran into this too…until I went back and actually read the
instructions on how
to upgrade from 0.13.x to 0.14.x. In a nutshell you need to do the
following:

  1. copy your app to another directory, unless you have it under version
    control
  2. go into your app directory and run ‘rails .’ to build a 0.14.x app
  3. compare the various config files of the new version to your old
    version,
    adding in any changes you made to the stock configuration
  4. then run the update_javascripts and add_new_scripts commands.

Hope that helps. Here’s the URL for the full instructions

http://manuals.rubyonrails.org/read/book/19