Document type / content type problems

Hello list,

I have a strange problem where one of my domains is experiencing
problems. The problem is that under Firefox, it gives me a prompt to
download the file rather than displaying it in the browser window. The
same domain works just fine under Safari or IE. I thought there is
some problem with the headers or something but I tried all I could and
the problem is still here:

if I do “curl -i” I get:

HTTP/1.1 200 OK
Server: nginx/0.6.30
Date: Thu, 01 May 2008 02:51:41 GMT
Content-Type: text/html; charset=utf-8
Content-Length: 4082
Last-Modified: Thu, 01 May 2008 01:18:04 GMT
Connection: keep-alive
Accept-Ranges: bytes

The domain in question is icepique.com

I do not even know what info to provide as I do not know what is
relevant so if you know what I should check first, let me know and I
can provide more info.

Thanks in advance,
Kiril

http://www.icepique.com/ works for me in Firefox 3.0b5. Did you
recently change the default content type? If so you could try
clearing cache.

Yes, I cleared the cache and it works on 2.x too. Strange, I did hard
refresh many times but yes I was trying to fix it so I guess something
worked :slight_smile:

Sorry to bother.

Kiril

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs