Do_sqlite3 - how to acquire & install latest version?

Apparently the reason I can’t use sqlite3 with Mac OS X is a bad
version of do_sqlite3. Could someone please spell out exactly what a
newbie needs to do to grab & reinstall the latest version?

Thanks,
jim

Perfect! Thanks very much.

Jim

Download the source from rubyforge:

http://rubyforge.org/projects/sqlite-ruby

Extract it and then cd into the extracted directory and run:

ruby setup.rb

Hope this helps.

Sheldon

I replied too soon, I still get the same error:

MissingSourceFile in HomeController#index

no such file to load – sqlite3

Glad it worked. I was stuck in the same predicament a few weeks back
and after going around in circles hit upon the solution.

Sheldon

Yes, and I reinstalled it as you suggested, but still no luck :frowning: Maybe
I’ll just switch to mysql for the time being…

bash-3.2$ sudo gem install sqlite3-ruby
Password:
Building native extensions. This could take a while…
Successfully installed sqlite3-ruby-1.2.4
1 gem installed
Installing ri documentation for sqlite3-ruby-1.2.4…
Installing RDoc documentation for sqlite3-ruby-1.2.4…
bash-3.2$

Looks like the problem has gone away. I restarted the web server and
it seems to now work fine. Go figure…

Thanks very much for your help.

Hmmm. Weird. Do you have the sqlite3 gem installed?

sudo gem install sqlite3-ruby

Sheldon F.
http://twitter.com/sheldonfinlay

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs