Dispatch.fcgi won't work


#1

Here’s what’s going on:

(23:51)bartek@ariel:~/dev/rails/scores$ ruby script/server
=> Booting lighttpd (use ‘script/server webrick’ to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
2007-07-31 23:52:52: (mod_fastcgi.c.998) execve failed for:
/home/bartek/dev/rails/scores/public/dispatch.fcgi Permission denied
2007-07-31 23:52:52: (mod_fastcgi.c.1024) the fastcgi-backend
/home/bartek/dev/rails/scores/public/dispatch.fcgi failed to start:
2007-07-31 23:52:52: (mod_fastcgi.c.1028) child exited with status 13
/home/bartek/dev/rails/scores/public/dispatch.fcgi
2007-07-31 23:52:52: (mod_fastcgi.c.1031) if you try do run PHP as
FastCGI backend make sure you use the FastCGI enabled version.
You can find out if it is the right one by executing ‘php -v’ and it
should display ‘(cgi-fcgi)’ in the output, NOT (cgi) NOR (cli)
For more information check
http://www.lighttpd.net/documentation/fastcgi.html#preparing-php-as-a-fastcgi-program
2007-07-31 23:52:52: (mod_fastcgi.c.1333) [ERROR]: spawning fcgi failed.
2007-07-31 23:52:52: (server.c.849) Configuration of plugins failed.
Going down.
Exiting
Couldn’t find any pid file in ‘/home/bartek/dev/rails/scores/tmp/pids’
matching ‘dispatch.[0-9]*.pid’
(also looked for processes matching
“/home/bartek/dev/rails/scores/public/dispatch.fcgi”)
(23:52)bartek@ariel:~/dev/rails/scores$

I tried to downgrade lighttpd. Then I tried to get and install the
newest php and compile it according to hints in the link. Php -v shows
me “cli” only. Dispatch.fcgi has perms 755, and group “lighttpd”.

What could be wrong?