Dislikes dual?

E:\installs>jruby --server --server
jruby: unknown option --server

is this expected?
Thanks.
-r

On Feb 13, 2010, at 11:58 PM, Roger P. wrote:

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Which version are you using? This doesn’t happen on trunk.

$ jruby -v --server --server -e ‘p 0’
jruby 1.5.0.dev (ruby 1.8.7 patchlevel 174) (2010-02-13 5c80717) (Java
HotSpot™ 64-Bit Server VM 1.6.0_17) [x86_64-java]
0


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Which version are you using? This doesn’t happen on trunk.

$ jruby -v --server --server -e ‘p 0’
jruby 1.5.0.dev (ruby 1.8.7 patchlevel 174) (2010-02-13 5c80717) (Java
HotSpot™ 64-Bit Server VM 1.6.0_17) [x86_64-java]
0

Interesting.

E:\dev\ruby\p2pwebclient\final>set JRUBY_OPTS=–server --server

E:\dev\ruby\p2pwebclient\final>jirb
jruby: unknown option --server

E:\dev\ruby\p2pwebclient\final>jruby -v
jruby 1.5.0.dev (ruby 1.8.7 patchlevel 174) (2010-02-08 13993be) (Java
HotSpot™ Client VM 1.6.0_17) [x86-java]

Windows has a native launcher now…perhaps it does not like the
double --server?

ponders where the source may be :slight_smile:

-Tom

On Mon, Feb 15, 2010 at 7:59 AM, Roger P. [email protected]
wrote:

E:\dev\ruby\p2pwebclient\final>set JRUBY_OPTS=–server --server


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


blog: http://blog.enebo.com twitter: tom_enebo
mail: [email protected]


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Folks,

Actually, both JRuby native launcher on Windows and shell launcher on
*nix don’t like --server option, when it set via JRUBY_OPTS. No need
to have a double --server at all. :slight_smile:

On Linux:

#>export JRUBY_OPTS=–server
#>jruby -v
jruby: unknown option --server

On Windows:

% set JRUBY_OPTS=–server
% jruby -v
jruby: unknown option --server

Thanks,
–Vladimir

On Mon, Feb 15, 2010 at 5:06 PM, Thomas E Enebo [email protected]
wrote:

jruby: unknown option --server


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs