Disabling the usrp2 in configure

I’m trying to disable the configure stuff for the USRP2 by passing
–disable-usrp2 to the configure script. Unfortunately, the
usrp2/firmware script is still trying to run. This dies when I am trying
to cross compile the code. For the OMAP3, I have no gig-E so I just want
the usrp2 stuff out of the way.

What is the best way to force the usrp2 configure stuff not to run at
all? I’ve pasted the error from config.log at the bottom of the email.

Philip

config.status:2173: executing run_tests_sdl commands
config.status:2173: executing run_tests_sounder commands
config.status:2173: executing run_tests_build commands
configure:50300: === configuring in usrp2/firmware
(/home/balister/oe/tmp/work/a
rmv7a-angstrom-linux-gnueabi/gnuradio-3.2.1-r7.1+gitr9d2c4b0625dac26c86974453518
aa5b034fc849e-r7.1/git/usrp2/firmware)
configure:50403: running /bin/sh ./configure.gnu
–disable-option-checking ‘–pr
efix=/usr’ ‘–build=x86_64-linux’
‘–host=armv7a-angstrom-linux-gnueabi’ ‘–tar
get=arm-angstrom-linux-gnueabi’ ‘–exec_prefix=/usr’ ‘–bindir=/usr/bin’
‘–sbin
dir=/usr/sbin’ ‘–libexecdir=/usr/libexec’ ‘–datadir=/usr/share’
‘–sysconfdir=
/etc’ ‘–sharedstatedir=/usr/com’ ‘–localstatedir=/var’
‘–libdir=/usr/lib’ ‘–
includedir=/usr/include’ ‘–oldincludedir=/usr/include’
‘–infodir=/usr/share/in
fo’ ‘–mandir=/usr/share/man’ ‘–program-prefix=’ ‘–with-md-cpu=arm’
‘–disable
-gr-atsc’ ‘–enable-gr-video-sdl’ ‘–enable-gr-audio-alsa’
‘–enable-gr-audio-ja
ck’ ‘–enable-gr-audio-oss’ ‘–enable-mblock’ ‘–disable-html-docs’
‘–with-pyth
ondir=/usr/lib/python2.6/site-packages’
‘PYTHON_CPPFLAGS=-I/home/balister/oe/tmp
/staging/armv7a-angstrom-linux-gnueabi/usr/include/python2.6’
‘–with-boost=/hom
e/balister/oe/tmp/staging/armv7a-angstrom-linux-gnueabi/usr’
‘CXXFLAGS=-DBOOST_S
P_USE_PTHREADS’ ‘–disable–usrp2’ ‘build_alias=x86_64-linux’
‘host_alias=armv7a
-angstrom-linux-gnueabi’ ‘target_alias=arm-angstrom-linux-gnueabi’
‘CC=ccache ar
m-angstrom-linux-gnueabi-gcc -march=armv7-a -mtune=cortex-a8 -mfpu=neon
-mfloat-
abi=softfp’
‘CFLAGS=-isystem/home/balister/oe/tmp/staging/armv7a-angstrom-linux-
gnueabi/usr/include -O -fno-omit-frame-pointer -g’
‘LDFLAGS=-L/home/balister/oe/
tmp/staging/armv7a-angstrom-linux-gnueabi/usr/lib
-Wl,-rpath-link,/home/balister
/oe/tmp/staging/armv7a-angstrom-linux-gnueabi/usr/lib -Wl,-O1
-Wl,–hash-style=g
nu’
‘CPPFLAGS=-isystem/home/balister/oe/tmp/staging/armv7a-angstrom-linux-gnueab
i/usr/include’ ‘CPP=arm-angstrom-linux-gnueabi-gcc -E’ ‘CXX=ccache
arm-angstrom-
linux-gnueabi-g++ -march=armv7-a -mtune=cortex-a8 -mfpu=neon
-mfloat-abi=softfp’
‘F77=ccache arm-angstrom-linux-gnueabi-g77 -march=armv7-a
-mtune=cortex-a8 -mfp
u=neon -mfloat-abi=softfp’
‘USB_LIBS=-L/home/balister/oe/tmp/work/armv7a-angstro
m-linux-gnueabi/gnuradio-3.2.1-r7.1+gitr9d2c4b0625dac26c86974453518aa5b034fc849e
-r7.1/libusb-0.1.12/.libs/ -l:libusb-gnur.a’ --cache-file=/dev/null
–srcdir=.
configure:50408: error: ./configure.gnu failed for usrp2/firmware

----------------

On Tue, Sep 15, 2009 at 13:57, Philip B. [email protected]
wrote:

I’m trying to disable the configure stuff for the USRP2 by passing
–disable-usrp2 to the configure script. Unfortunately, the usrp2/firmware
script is still trying to run. This dies when I am trying to cross compile
the code. For the OMAP3, I have no gig-E so I just want the usrp2 stuff out
of the way.

configure --disable-usrp2 --disable-usrp2-firmware

Johnathan

On Tue, Sep 15, 2009 at 04:57:32PM -0400, Philip B. wrote:

I’m trying to disable the configure stuff for the USRP2 by passing
–disable-usrp2 to the configure script. Unfortunately, the
usrp2/firmware script is still trying to run. This dies when I am trying
to cross compile the code. For the OMAP3, I have no gig-E so I just want
the usrp2 stuff out of the way.

OK.

From the log below it looks like you passed --disable–usrp2
(two dashes) instead of --disable-usrp2 (one dash).

What is the best way to force the usrp2 configure stuff not to run at
all? I’ve pasted the error from config.log at the bottom of the email.

Philip

If that doesn’t fix it, write again. I’ve got some more ideas.

Eric

Eric B. wrote:

(two dashes) instead of --disable-usrp2 (one dash).

What is the best way to force the usrp2 configure stuff not to run at
all? I’ve pasted the error from config.log at the bottom of the email.

Philip

If that doesn’t fix it, write again. I’ve got some more ideas.

Fixing the typo (the problem with automation, it preserves your mistakes
across runs) and adding the --disable-usrp2-firmware did not help. The
log is at the bottom of the email.

Patching out the GRC_GR_USRP2 line “solves” the problem, but I do not
want to carry this patch around anymore.

I’ll be glad to look at your suggestions in the morning!

Philip

Philip B. wrote:

(two dashes) instead of --disable-usrp2 (one dash).
across runs) and adding the --disable-usrp2-firmware did not help. The
log is at the bottom of the email.

Patching out the GRC_GR_USRP2 line “solves” the problem, but I do not
want to carry this patch around anymore.

I’ll be glad to look at your suggestions in the morning!

OK, I found the root problem. Basically, in the usrp2 firmware build
process, there is a wrapper configure.gnu that unsets environment vars
and removes extra arguments to the configure used to build the firmware.
Since I am passing the USB_* vars on the command line, they upset the
configure script.

Updating configure.gnu to reomve them solves my problem. The larger
question is, should I go ahead and account for the other influential
variables listed in the help for the gnuradio configure script.

CCAS assembler compiler command (defaults to CC)
CCASFLAGS assembler compiler flags (defaults to CFLAGS)
F77 Fortran 77 compiler command
FFLAGS Fortran 77 compiler flags
PKG_CONFIG path to pkg-config utility
FFTW3F_CFLAGS
C compiler flags for FFTW3F, overriding pkg-config
FFTW3F_LIBS linker flags for FFTW3F, overriding pkg-config
FFTW3F_INCLUDEDIR
includedir for FFTW3F, overriding pkg-config
CPPUNIT_CFLAGS
C compiler flags for CPPUNIT, overriding pkg-config
CPPUNIT_LIBS
linker flags for CPPUNIT, overriding pkg-config
CPPUNIT_INCLUDEDIR
includedir for CPPUNIT, overriding pkg-config
GSL_CFLAGS C compiler flags for GSL, overriding pkg-config
GSL_LIBS linker flags for GSL, overriding pkg-config
GSL_INCLUDEDIR
includedir for GSL, overriding pkg-config
USB_CFLAGS C compiler flags for USB, overriding pkg-config
USB_LIBS linker flags for USB, overriding pkg-config
USB_INCLUDEDIR
includedir for USB, overriding pkg-config
ALSA_CFLAGS C compiler flags for ALSA, overriding pkg-config
ALSA_LIBS linker flags for ALSA, overriding pkg-config
ALSA_INCLUDEDIR
includedir for ALSA, overriding pkg-config
JACK_CFLAGS C compiler flags for JACK, overriding pkg-config
JACK_LIBS linker flags for JACK, overriding pkg-config
JACK_INCLUDEDIR
includedir for JACK, overriding pkg-config
PORTAUDIO_CFLAGS
C compiler flags for PORTAUDIO, overriding pkg-config
PORTAUDIO_LIBS
linker flags for PORTAUDIO, overriding pkg-config
PORTAUDIO_INCLUDEDIR
includedir for PORTAUDIO, overriding pkg-config
COMEDI_CFLAGS
C compiler flags for COMEDI, overriding pkg-config
COMEDI_LIBS linker flags for COMEDI, overriding pkg-config
COMEDI_INCLUDEDIR
includedir for COMEDI, overriding pkg-config
SDL_CFLAGS C compiler flags for SDL, overriding pkg-config
SDL_LIBS linker flags for SDL, overriding pkg-config
SDL_INCLUDEDIR
includedir for SDL, overriding pkg-config
QTCORE_CFLAGS
C compiler flags for QTCORE, overriding pkg-config
QTCORE_LIBS linker flags for QTCORE, overriding pkg-config
QTCORE_INCLUDEDIR
includedir for QTCORE, overriding pkg-config
QTGUI_CFLAGS
C compiler flags for QTGUI, overriding pkg-config
QTGUI_LIBS linker flags for QTGUI, overriding pkg-config
QTGUI_INCLUDEDIR
includedir for QTGUI, overriding pkg-config
QTOPENGL_CFLAGS
C compiler flags for QTOPENGL, overriding pkg-config
QTOPENGL_LIBS
linker flags for QTOPENGL, overriding pkg-config
QTOPENGL_INCLUDEDIR
includedir for QTOPENGL, overriding pkg-config

Philip

On Thu, Sep 17, 2009 at 07:58:17AM -0400, Philip B. wrote:

Philip B. wrote:

OK, I found the root problem. Basically, in the usrp2 firmware build
process, there is a wrapper configure.gnu that unsets environment vars
and removes extra arguments to the configure used to build the firmware.
Since I am passing the USB_* vars on the command line, they upset the
configure script.

If they are well-formed, I’m not sure how this could cause a problem.
They are not referenced by anything in the firmware build. The ones
in yesterday’s logs were not well-formed; they had spaces embedded in
them and probably we’re leading to a syntax error somewhere in the
guts of configure (actually looks like the problem may be in
configure.gnu (shell quoting across shell scripts is hard to get
right.) Probably ought to rewrite configure.gnu as a python script.
That way arg handling wouldn’t be borked.)

Updating configure.gnu to remove them solves my problem. The larger
question is, should I go ahead and account for the other influential
variables listed in the help for the gnuradio configure script.

Yes, please add these to the list:

CCAS assembler compiler command (defaults to CC)
CCASFLAGS assembler compiler flags (defaults to CFLAGS)

Already on the list:

F77 Fortran 77 compiler command
FFLAGS Fortran 77 compiler flags

I don’t think we need to remove any of these, the firmware doesn’t
look at any of them.

CPPUNIT_INCLUDEDIR
ALSA_LIBS linker flags for ALSA, overriding pkg-config
PORTAUDIO_INCLUDEDIR
QTCORE_CFLAGS
C compiler flags for QTOPENGL, overriding pkg-config
QTOPENGL_LIBS
linker flags for QTOPENGL, overriding pkg-config
QTOPENGL_INCLUDEDIR
includedir for QTOPENGL, overriding pkg-config

Philip

Let me know how it goes!

Eric

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs