Disabling a form

This is what I have:

<% remote_form_for :message,
:url => { :action => ‘add_followup’ },
:loading => “$(‘followup_form’).disable();”, :complete => “$
(‘followup_form’).enable;”,
:html => { :id => ‘followup_form’ } do |form| %>

<% end %>

It works fine on FF, but not on Safari.
Where’s the mistake here ?

ngw

Nicholas W. wrote:

(‘followup_form’).enable;",

uh, enable() <-- ?


Phlip
http://c2.com/cgi/wiki?ZeekLand <-- NOT a blog!!

Il giorno 08/mar/07, alle ore 15:18, Phlip ha scritto:

Nicholas W. wrote:

(‘followup_form’).enable;",

uh, enable() <-- ?

No …
The problem is with disable(), it doesn’t disable anything …

ngw

Nicholas W. wrote:

The problem is with disable(), it doesn’t disable anything …

Try viewing your page, using View Source, copy out the generated
JavaScript, and pasting it here.


Phlip
http://c2.com/cgi/wiki?ZeekLand <-- NOT a blog!!

Nicholas W. wrote:

$(‘followup_form’).enable();

I never had any luck with that. Try Form.Enable(“followup_form”) -
Google for it first!


Phlip
http://c2.com/cgi/wiki?ZeekLand <-- NOT a blog!!

Il giorno 08/mar/07, alle ore 16:09, Phlip ha scritto:

Nicholas W. wrote:

The problem is with disable(), it doesn’t disable anything …

Try viewing your page, using View Source, copy out the generated
JavaScript, and pasting it here.

TIA,
ngw

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs