--disable-gems permanent?

Before I report a bug report to core on this one, thought I’d see if
anybody had some feedback first.

Currently with 1.9.1, if you run
$ ruby --disable-gems test.rb


test.rb is:
require ‘rubygems’
require ‘gem_name’

I get:

C:\installs\ruby191p376\lib\ruby\gems\1.9.1\gems\redcar-0.3.3>ruby -v
–disable-gems test.rb
ruby 1.9.2dev (2010-03-24) [i386-mingw32]
Win32API is deprecated after Ruby 1.9.1; use dl directly instead
test.rb:2:in require': no such file to load -- win32/api (LoadError) from test.rb:2:in

and am forced to instead fo

require ‘rubygems’
gem ‘gem_name’
require ‘gem_name’

I assume this is unexpected to others, as well?