--disable-all-components --enable-gr-usrp doesn't built

G’day,

./configure --sysconfdir=/usr/pkg/share/examples
–disable-all-components --without-libintl-prefix --prefix=/usr/pkg
–host=i386–netbsdelf --mandi
r=/usr/pkg/man

doesn’t build due to usrp not being build.

To reproduce, on a system with the usrp-module already installed,
install a
fresh tarball and try to build gr-usrp only.

The following comment was found inside the configure script:

# Don't do gr-usrp if usrp skipped
# There *has* to be a better way to check if a value is in a string

I consider this to be a bug since configure should check for
availability of
the usrp-module system wide and not just inside the tarball package.

I successfully built gr-usrp after bypassing this limitation.

Whilst most users will build usrp and gr-usrp together, IMHO, a fix is
desirable in order to be consistent and enable modular packaging of
gnuradio.

cheerio Berndt

On Sat, Nov 11, 2006 at 07:39:37PM +1030, Berndt Josef W. wrote:

G’day,

./configure --sysconfdir=/usr/pkg/share/examples --disable-all-components --without-libintl-prefix --prefix=/usr/pkg --host=i386–netbsdelf --mandi
r=/usr/pkg/man

doesn’t build due to usrp not being build.

Whilst most users will build usrp and gr-usrp together, IMHO, a fix is
desirable in order to be consistent and enable modular packaging of gnuradio.

Please create a new ticket for this issue in Trac.
Login in as user: guest, password: gnuradio, then select “New Ticket”.

There was some discussion of this a while ago, but it apparently
didn’t result in an ticket being created.

Eric

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs