Differences between Ruby 1.9.2 and 1.9.3

Hi,

First of all keep in mind I am completely new to Ruby, plus I am
sysadmin, not developer.

As sysadmin I started working in company that do have some Ruby
applications running on Ubuntu 11.10 with Ruby 1.9.2. I wanted to
migrate those applications to Ubuntu 12.04 with out of box ruby (ver
1.9.3) but it is not working, I am receiving lot’s of errors. (mainly
around ruby-debug and parseline if I understand properly)

My question is what are main differences between those two versions of
Ruby ? Where I should start looking ? What is best method for this port
?

Thank you in advance.

Best regards,
Dusan

On Fri, Mar 22, 2013 at 2:40 PM, Dusan D. [email protected] wrote:

My question is what are main differences between those two versions of
Ruby ? Where I should start looking ? What is best method for this port
?

First hit when throwing the subject line at Google:
http://www.rubyinside.com/ruby-1-9-3-introduction-and-changes-5428.html

Does that help?

Cheers

robert

On Fri, Mar 22, 2013 at 2:54 PM, Dusan D. [email protected] wrote:

I checked that text and it is not helping. According that one, it should
not be major change, everything should be working straightforward. And
yet I do have problems.

btw. problem is with linecache19 (not parseline as I previously stated).

What about posting the concrete error? That’ll likely yield more
helpful answers. :slight_smile:

The only other thing that comes to mind is to check whether gems are
current.

Cheers

robert

Hi Robert,

I checked that text and it is not helping. According that one, it should
not be major change, everything should be working straightforward. And
yet I do have problems.

btw. problem is with linecache19 (not parseline as I previously stated).

Did you reinstall your gems too?

Hi,

The error I am seeing is this:

/var/lib/gems/1.9.1/gems/linecache19-0.5.12/lib/tracelines19.rb:12:in
`require’:
/var/lib/gems/1.9.1/gems/linecache19-0.5.12/lib/trace_nums19.so:
undefined symbol: ruby_current_thread -
/var/lib/gems/1.9.1/gems/linecache19-0.5.12/lib/trace_nums19.so
(LoadError)

I guess gems are OK, I updated Ubuntu to latest version of everything
using “apt-get upgrade”

Thanks.

On Fri, Mar 22, 2013 at 3:33 PM, Dusan D. [email protected] wrote:

I guess gems are OK, I updated Ubuntu to latest version of everything
using “apt-get upgrade”

To elaborate what Hans said: you also need “sudo gem update” (or
without “sudo” depending on where you store your gems) followed by
“sudo gem clean”.

Cheers

robert

Yes, I’ve done that and still the same. Reading around the internet, it
seems that I’ve hit well known bug that was not fixed for a year or so
(http://devnet.jetbrains.com/thread/431168).

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs