Devise and Mailer

Hello all,

I am trying to get Devise and Mailer to work together. Whenever I send
an email for the "Forget password’ section. It says: “You will receive
an email with instructions about how to reset your password in a few
minutes.”

I am trying to send this to my gmail account for testing purposes.
After a few minutes, I do not receive any email at all.

So far in /config/environment.rb. I’ve got the following code:

config.action_mailer.default_url_options = { :host => ‘localhost:
3000’ }
config.action_mailer.delivery_method = :smtp
config.action_mailer.smtp_settings = {
:enable_startttls_auto => true,
:address => ‘smtp.gmail.com’,
:port => ‘587’,
:authentication => :plain,
:domain => ‘myapp.com’,
:user_name => ‘[email protected]’,
:password => ‘my_actual_password’
}

Are these settings correct?

Hoping to hear from you soon.

I am using Ruby 1.8.7, Rails 2.3.8

On Aug 23, 11:06 am, Christian F. [email protected]

Ok figured out the problem. The reason why it wasn’t reporting any
errors was because I had

config.action_mailer.raise_delivery_errors = false

in my /config/environments/development.rb file

Second, my configuration is wrong. I had:

:enable_startttls_auto => true,

Should be,

:enable_starttls_auto => true,

I restarted the server, and am now receiving emails as should be.

On Aug 23, 5:55 pm, Christian F. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs