Depot Application

Hello All,

I am doing the depot appliction.

I was first installed Instant Rails 2.0 on my machine.

got error in getting scaffold :product

then after searching in forum took the 1.2.6 version using the below
command

gem install rails --version 1.2.6 --include-dependencies

Now i am getting the error after starting the server

ruby script/server

got the below error

D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:334:in
send': undefined methodsession=’ for ActionController::Base:Class
(NoMethodError)
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:334:in
initialize_framework_settings' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:333:ineach’
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:333:in
initialize_framework_settings' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:330:ineach’
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:330:in
initialize_framework_settings' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:100:inprocess’
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:47:in
send' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:47:inrun’
… 27 levels…
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/commands/server.rb:39
from
D:/Rails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from D:/Rails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from script/server:3

Did you create the depot project when 2.0 was installed? You may have
to go into your environment file and change the rails version to
1.2.6.
config > environment.rb > RAILS_GEM_VERSION

Matt

On May 9, 1:45 am, Vijay R. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs