Depot Application not working

Hello All,

I am doing the depot appliction.

I was first installed Instant Rails 2.0 on my machine.

got error in getting scaffold :product

then after searching in forum took the 1.2.6 version using the below
command

gem install rails --version 1.2.6 --include-dependencies

Now i am getting the error after starting the server

ruby script/server

got the below error

D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:334:in
send': undefined methodsession=’ for ActionController::Base:Class
(NoMethodError)
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:334:in
initialize_framework_settings' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:333:ineach’
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:333:in
initialize_framework_settings' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:330:ineach’
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:330:in
initialize_framework_settings' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:100:inprocess’
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:47:in
send' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:47:inrun’
… 27 levels…
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/commands/server.rb:39
from
D:/Rails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from D:/Rails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from script/server:3

On May 9, 11:01 am, Vijay R. [email protected]
wrote:

gem install rails --version 1.2.6 --include-dependencies

Regenerate your application with rails 1.2.6 (rails 1.2.6 myapp).
the one generated by rails 2.0 references stuff that doesn’t exist in
1.2.6

Fred

step 1: Have a look in to this link, if it doesn’t happen better
switch over to step 2.

http://leonardoborges.com/writings/2007/12/21/rails-20-scaffold/

step 2: Try the same with rails 1.2.3, Dynamic scaffolding is no longer
available in rails 2.0.

Vijay R. wrote:

Hello All,

I am doing the depot appliction.

I was first installed Instant Rails 2.0 on my machine.

got error in getting scaffold :product

then after searching in forum took the 1.2.6 version using the below
command

gem install rails --version 1.2.6 --include-dependencies

Now i am getting the error after starting the server

ruby script/server

got the below error

D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:334:in
send': undefined methodsession=’ for ActionController::Base:Class
(NoMethodError)
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:334:in
initialize_framework_settings' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:333:ineach’
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:333:in
initialize_framework_settings' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:330:ineach’
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:330:in
initialize_framework_settings' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:100:inprocess’
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:47:in
send' from D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:47:inrun’
… 27 levels…
from
D:/Rails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/commands/server.rb:39
from
D:/Rails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from D:/Rails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from script/server:3

Simply installing the 1.2.6 gem doesn’t magically make your rails
command use 1.2.6, if you have 2.x installed. It’ll always use the
latest version unless you specify otherwise. What you need to do is
issue the following command:

 rails _1.2.6_ depot

That should make it so you can follow the tutorials without any issues
related to changes from 2.x that might not be compatible with the book
you’re reading from. You also need to make sure you do this without
overwriting your existing depot 2.x rails app – I’m not sure what’d
happen if you did so (it might work but it might not). To avoid any
headaches I’d delete your depot project, and regenerate the 1.2.6
project from scratch.

Nicholas

On May 9, 5:01 am, Vijay R. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs