Deployment Problem

I’ve recently tried to get an application running on GoDaddy and after
a few days gave up (their support team was very unhelpful). Anyhow, I
changed hosting to Rails Playground.
I now get a new error when running the dispatch.fcgi:

================================
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require': no such file to load -- ferret (MissingSourceFile) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:inrequire’
from …/config/…/vendor/rails/activerecord/lib/…/…/
activesupport/lib/active_support/dependencies.rb:495:in require' from ../config/../vendor/rails/activerecord/lib/../../ activesupport/lib/active_support/dependencies.rb:342:innew_constants_in’
from …/config/…/vendor/rails/activerecord/lib/…/…/
activesupport/lib/active_support/dependencies.rb:495:in `require’
from …/config/…/vendor/plugins/acts_as_ferret/lib/
acts_as_ferret.rb:25

Furthermore the support team also said:
Note that the gem acts_as_ferret (0.4.1) is already installed in your
server.

Would anyone have any idea what line of code I should change?

TIA,
Elle

Try gem install ferret

I’m pretty sure ferret and acts_as_ferret are different gems.
-Ivan

I had acts_as_ferret on my computer though

Elle

I’ll ask another question. So, I ran “gem install ferret” and it told
me: “Successfully installed ferret-0.11.6”
but then when I started the web server (mongrel on my local machine) I
now get this:

** Starting Rails with development environment…
Exiting
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/
active_support/dependencies.rb:263:in load_missing_constant': uninitialized constant Ferret::Analysis::Analyzer (NameError) from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/ active_support/dependencies.rb:452:inconst_missing’
from ./script/…/config/…/vendor/plugins/acts_as_ferret/lib/
ferret_extensions.rb:17
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:inrequire’
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/
active_support/dependencies.rb:495:in require' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/ active_support/dependencies.rb:342:innew_constants_in’
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/
active_support/dependencies.rb:495:in require' from ./script/../config/../vendor/plugins/acts_as_ferret/lib/ acts_as_ferret.rb:28 ... 42 levels... from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/ commands/server.rb:39 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:ingem_original_require’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in `require’
from script/server:3

What do I need to do to fix this?
And what would I need to do in order to get this working on the web
server?

TIA,
Elle

Actually, defining development environment made the server start.
But I’m still having the problems above with the web server in
production mode.

Does anyone know what the problem is?

Elle

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs