Deploy su heroku

Ciao,
ho creato in locale un applicazione ror funzionante. Ho fatto il commit
su git e successivamente il deploy su heroku.
tutto è andato a buon fine e quando digito l indirizzo pubblico del mio
deploy vedo la home page, tutta via quando cerco di accedere altre
pagine (about,contatti ect ect) heroku mi risponde con “We’re sorry, but
something went wrong.2”
Sinceramente non saprei dove guardare visto che heroku non mi ritorna
nessun codice d’errore a video.
In allegato il mio gemfile, magari può essere utile.

Grazie a chi mi da un consiglio

Il log che dice?
https://devcenter.heroku.com/articles/logging

i.

ciao,

puoi fare:

heroku logs

per guardare i log di Heroku e capire di pi del tuo problema, have fun
:wink:

La butto l, hai fatto le migration per il db su heroku?

cos a naso, ho un paio di sospetti:

  1. mi sa tanto che quell’errore non appartenga ai logs della tua app.
    sembra che l’errore sia riferito al client di heroku

  2. ti consiglio comunque di consultare i logs su heroku in tempo reale,
    altrimenti riceverai un output troppo breve e non necessariamente
    riferito agli errori che hai ricevuto. usa l’opzione “–tail”

$ heroku log --tail

vai sul sito e riprova ad accedere alle pagine che ti danno errore, poi
torna alla shell e killa i logs (ctrl-c)

ciao,
A.

Il giorno 23/lug/2013, alle ore 14:41, asd asd [email protected]
ha scritto:

Error: Permission denied - /home/bitnami/.netrc


http://andreapavoni.com

grazie a tutti,
il log:

! Heroku client internal error.
! Search for help at: https://help.heroku.com
! Or report a bug at: https://github.com/heroku/heroku/issues/new

Error:       Permission denied - /home/bitnami/.netrc 

(Errno::EACCES)
Backtrace:
/usr/local/heroku/vendor/gems/netrc-0.7.7/lib/netrc.rb:37:in read' /usr/local/heroku/vendor/gems/netrc-0.7.7/lib/netrc.rb:37:inread’
/usr/local/heroku/lib/heroku/auth.rb:119:in netrc' /usr/local/heroku/lib/heroku/auth.rb:143:inread_credentials’
/usr/local/heroku/lib/heroku/auth.rb:84:in
get_credentials' /usr/local/heroku/lib/heroku/auth.rb:70:inuser’
/usr/local/heroku/lib/heroku/auth.rb:33:in client' /usr/local/heroku/lib/heroku/command/base.rb:44:inheroku’
/usr/local/heroku/lib/heroku/command/logs.rb:32:in
index' /usr/local/heroku/lib/heroku/command.rb:206:inrun’
/usr/local/heroku/lib/heroku/cli.rb:28:in start' /usr/local/heroku/bin/heroku:25:in

Command:     heroku logs
Version:     heroku-toolbelt/2.39.0 (x86_64-linux) ruby/1.9.3

La migrazione non l’ho fatta, so che heroku necessita di postgres allora
ho aggiunto al gemfile la gemma per ps. Dovevo fare qualcos altro?
Scusate la banalità ma nonostante abbia programmato con altri linguaggi
sono agli inizi con ror