Debugging a Rails 3 app with RadRails 2?

When trying to debug a Rails 3 app with RadRails 2.0.4, I’m running into
a problem with gem loading, apparently. See below for a stack trace.
That problem disappears, when I move Gemfile out of the way, but, of
course, then other necessary gems aren’t loaded.

From my Debug Configuration

File: script/rails
Working Directory: /home/michael/aptana/
Interpreter Arguments: -e STDOUT.sync=true -e STDERR.sync=true -e
Programm Arguments: server --debugger --environment=development –
Interpreter: standard /usr/bin/ruby

I’ve tried adding/removing ruby-debug and ruby-debug-ide to the Gemfile
in any order and at the top-level as well as in the :development group.

I think, but are far from sure, that RadRails and Bundler are of devided
minds as to which gems are active when. First, RadRails directly runs
rdebug-ide, which runs script/rails which causes bundler to mangle which
gems are active. In the file, where the error occurs, there’s a

require ‘ruby-debug/processor’

and that succeeds. But possibly it loads the wrong file, i.e. not the
one from ruby-debug, but the one from ruby-debug-ide. The later does
indeed not define Debugger::CommandProcessor. (I’m using Ruby 1.8.7 and
this might matter here.)

I’ve tried my luck with the latest beta of Aptana Studio 3 as well, but
that wasn’t a pleasant experience, either.

I’m hoping someone has an idea how to get around this problem. I’m also
taking suggestions for other Linux-based(!) IDEs with suitable debugging
abilities :frowning:


Fast Debugger (ruby-debug-ide 0.4.9) listens on :2984
require' /var/lib/gems/1.8/gems/bundler-0.9.26/lib/bundler/runtime.rb:46:in require’
each' /var/lib/gems/1.8/gems/bundler-0.9.26/lib/bundler/runtime.rb:41:in require’
each' /var/lib/gems/1.8/gems/bundler-0.9.26/lib/bundler/runtime.rb:40:in require’
/var/lib/gems/1.8/gems/bundler-0.9.26/lib/bundler.rb:89:in `require’


tap' /var/lib/gems/1.8/gems/railties-3.0.0.beta4/lib/rails/commands.rb:27 ./script/rails:6:in require’
ide.rb:109:in debug_load' /var/lib/gems/1.8/gems/ruby-debug-ide-0.4.9/lib/ruby-debug- ide.rb:109:in debug_program’
/var/lib/gems/1.8/bin/rdebug-ide:19:in load' /var/lib/gems/1.8/bin/rdebug-ide:19 -e:3:in load’
Uncaught exception: uninitialized constant Debugger::CommandProcessor

Michael S.
mailto:[email protected]