Debugger rails con ruby-debug

Non riesco ad utilizzare il debug.
Ho scaricato la gemma e l’ho installata, ho modificato il file
development.rb inserendo queste due righe:
require ‘ruby-debug’
Debugger.start

fin quà tutto ok ma non ho capito come far partire webrick in modalitÃ
debug, negli esempi scrivono rdebug ma a me da comando sconosciuto
(giustamente) quindi penso di aver tralasciato qualche cosa ma non
capisco cosa.

Ho seguito questa guida:

http://wiki.rubyonrails.org/rails/pages/HowtoDebugWithRubyDebug

e questa

http://www.datanoise.com/articles/2006/9/15/debugging-rails-application

Più semplicemente:
require ‘rubygems’
require ‘ruby-debug’

Nel codice usa la chiamata al metodo ‘debugger’ come breakpoint e avvia
webrick normalmente.


blog: www.lucaguidi.com

Speaker at:
Rails To Italy '07 Conference
Oct, 26-27 2007 - Pisa
www.railstoitaly.org

Luca G. wrote:

Più semplicemente:
require ‘rubygems’
require ‘ruby-debug’

Nel codice usa la chiamata al metodo ‘debugger’ come breakpoint e avvia
webrick normalmente.


blog: www.lucaguidi.com

Speaker at:
Rails To Italy '07 Conference
Oct, 26-27 2007 - Pisa
www.railstoitaly.org

La riga require ‘rubygems’ non l’ho usata ma ora funziona grazie
Io facevo la require di ‘ruby-debug-base’ pensando che fosse
l’alternativa per win32 invece vanno installate entrambe le gemme, prima
la base e poi la ‘ruby-debug’.
Un altro problemino che ho avuto: installandole da locale installa
sempre la base anche se si scrive gem install ‘ruby-debug’ …percui è
necessario spostare dalla cartella la base dopo averla installata.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs