Dbd-odbc gem not

I have an application that requires dbd-odbc gem in order to work. So I
have to following in the environment.rb:


config.gem ‘dbd-odbc’, :version => ‘0.2.4’, :lib => ‘dbd/ODBC’

I recently had to switch to a new computer, so new install of ubuntu,
rails, gems, etc. I installed dbd-odbc as you can see:


$ gem list

dbd-odbc (0.2.4)

my app keeps failing though, and if I run a rake, it tries to reinstall
the same gem each time, but then the app still doesn’t see it:


$ sudo rake gems:install
[trace …]
no such file to load – dbd-odbc
[trace …]
gem install dbd-odbc --version “= 0.2.4”
Successfully installed dbd-odbc-0.2.4
1 gem installed
Installing ri documentation for dbd-odbc-0.2.4…
Installing RDoc documentation for dbd-odbc-0.2.4…

Has anyone seen this behavior before?

Thanks for any help!

-Ben

FYI: I un-installed and re-installed Ruby, rails, and Rubygems. Still
getting the SAME error. Any help would be rally appreciated, I’ve burned
so many hours on this stupid little problem now.

Thanks

-Ben

It’s not the gem that’s missing. It’s the Ruby ODBC bindings which you
need from here: http://www.ch-werner.de/rubyodbc/.

Once the correct Ruby bindings are installed, you can require ‘odbc’
with no dependencies.

HTH,
Dave

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs