DB2 9.7 + Rails 3.0.7 + Ruby 1.9.2 + Win Server 2008 R2 problem

Hi all,

also posted this message here (http://rubyforge.org/forum/forum.php?
thread_id=49785&forum_id=9503), but afterwards I found this group and
think it is more suitable to ask that question in this group!

I am using Windows Server 2008 R2 and try to get RoR to work for the
last three days. Basically I did the following

  1. Installed Ruby 1.9.2 with Ruby installer
  2. Installed gem
  3. Installed rails 3.0.7
  4. installed DB2 with gem install ibm_db

When I enetered irb and executed the command “require ‘ibm_db’” as
suggested here
http://publib.boulder.ibm.com/infocenter/db2luw/v9r5/index.jsp?topic=/com.ibm.db2.luw.apdv.ruby.doc/doc/t0052765.html
I got an error, that the DB2CLI.dll is missing, so I did some internet
research and found out here that the installation of “IBM Data Server
Driver for ODBC and CLI (Windows/x86-64 64 bit) V9.7 Fix Pack 4” is
necessary. So I installed it but the error message still appeared, so
I manually copied “C:\db2_cli_odbc_driver\clidriver\bin” to “C:
\Ruby192\bin”

When I executed the command “require ‘ibm_db’” again, the following
error message appeared:

irb(main):001:0> require ‘ibm_db’
LoadError: 14001: The application has failed to start because its side-
by-side configuration is incorrect. Please see the application event
log or use the comma
nd-line sxstrace.exe tool for more detail. - C:/Ruby192/lib/ruby/gems/
1.9.1/gems/ibm_db-2.5.6-x86-mingw32/lib/mswin32/rb19x/ibm_db.so
from C:/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:
59:in require' from C:/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb: 59:inrescue in require’
from C:/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:
35:in require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/ibm_db-2.5.6-x86-mingw32/lib/ mswin32/ibm_db.rb:1:in<top (required)>’
from C:/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:
36:in require' from C:/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb: 36:inrequire’
from C:/Ruby192/lib/ruby/gems/1.9.1/gems/ibm_db-2.5.6-x86-mingw32/lib/
IBM_DB.rb:1:in <top (required)>' from <internal:lib/rubygems/custom_require>:33:inrequire’
from internal:lib/rubygems/custom_require:33:in rescue in require' from <internal:lib/rubygems/custom_require>:29:inrequire’
from (irb):1
from C:/Ruby192/bin/irb:12:in `’
irb(main):002:0>

I also installed VC_redist 2005 and 2010.

I hope that anybody can help me with that problem.

Sent from my iPhone

On May 14, 2011, at 12:54 PM, Wolfgang [email protected] wrote:

  1. Installed gem
  2. Installed rails 3.0.7
  3. installed DB2 with gem install ibm_db

Have you tried uninstalling and reinstalling the gem for ibm_db?

B.

Yeah I have tried that several times, the problem resists. I also
installed the 32 bit version of DB2CLI.DLL in the meanwhile but this
also didn’t do the trick!

so,

does the file C:\Ruby192\bin\DB2CLI.dll exist and registered properly?
btw, why are you using
“require ‘ibm_db’” instead of “require ‘mswin32/ibm_db’” ?

tom

On May 15, 2011, at 11:22 , Wolfgang wrote:

could not be found. Please use sxstrace.exe for detailed diagnosis.

On May 14, 2011, at 12:54 PM, Wolfgang [email protected] wrote:

  1. Installed Ruby 1.9.2 with Ruby installer
    http://publib.boulder.ibm.com/infocenter/db2luw/v9r5/index.jsp?topic=
    irb(main):001:0> require ‘ibm_db’
    35:in require' from <internal:lib/rubygems/custom_require>:29:inrequire’

To post to this group, send email to [email protected]
To unsubscribe from this group, send email to
[email protected]
For more options, visit this group at
http://groups.google.com/group/rubyonrails-talk?hl=en.

Tomas Meinlschmidt, MS {MCT, MCP+I, MCSE, AER}, NetApp Filer/NetCache

www.meinlschmidt.com www.maxwellrender.cz www.lightgems.cz

hi,

what about running sxstrace.exe from console and paste the output?

does this file exist?
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ibm_db-2.5.6-x86-mingw32/lib/mswin32/rb19x/ibm_db.so

tom

On May 15, 2011, at 10:24 , Wolfgang wrote:

  1. installed DB2 with gem install ibm_db

When I executed the command “require ‘ibm_db’” again, the following
from C:/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:
IBM_DB.rb:1:in `<top (required)>’


You received this message because you are subscribed to the Google G.
“Ruby on Rails: Talk” group.> To post to this group, send email
[email protected]> To unsubscribe from this group, send email
[email protected]

For more options, visit this group
athttp://groups.google.com/group/rubyonrails-talk?hl=en.


You received this message because you are subscribed to the Google G. “Ruby
on Rails: Talk” group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to
[email protected]
For more options, visit this group at
http://groups.google.com/group/rubyonrails-talk?hl=en.


Maxwell Render CZ
Autorizovany distributor Maxwell renderu pro Ceskou republiku

hi!

  1. Yes, the file exists

The application event log says:

Activation context generation failed for “C:\Ruby192\bin\DB2CLI.dll”.
Dependent Assembly
IBM.DB2.CLI,language="*",processorArchitecture=“x86”,type=“win32”,version=“9.1.0.000”
could not be found. Please use sxstrace.exe for detailed diagnosis.

sxstrace.exe requires an .etl file wich seems to be not produced by
ruby!

Sent from my iPhone

On May 15, 2011, at 5:05 AM, Wolfgang [email protected] wrote:

Sorry, I am using “require ‘mswin32/ibm_db’” I just copied the wrong
line out from the IBM manual!

the DLL in C:\Ruby192\bin\DB2CLI.dll does exist, how can I check
whether it is registered proberly?

Try registering it again. Here are the steps. They should be good for
the version of Windows you are using.

http://www.winvistaclub.com/e43.html

B.

Its not possible for me to execute the command because after I press
enter the error “The module ‘db2cli.dll’ was loaded but the entry-
point DllRegisterServer was not found. Make sure that ‘db2cli.dll’ is
a valid DLL or OCX file and then try again.”

Any ideas?

Sorry, I am using “require ‘mswin32/ibm_db’” I just copied the wrong
line out from the IBM manual!

the DLL in C:\Ruby192\bin\DB2CLI.dll does exist, how can I check
whether it is registered proberly?

Thank you for your help!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs