Db:migrate fails after upgrade to Rails 2.3.5

Hi – I’m upgrading an app from Rails 2.0.2 to 2.3.5 in development on
a Mac OS/X Leopard. I unfroze the old Rails files, froze the 2.3.5
gem on the machine into the app, and some quick tests of the app
showed no problems.

However, after trying to run rake db:migrate, it fails silently. Run
with trace I get the output below. I gather it might be related to
plugin initialization or load paths, but I haven’t been able to find
any info despite searching for a while. Any suggestions greatly
appreciated!

** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:778: warning: instance variable @reload_plugins not
initialized
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:778: warning: instance variable @reload_plugins not
initialized
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:778: warning: instance variable @reload_plugins not
initialized
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:778: warning: instance variable @reload_plugins not
initialized
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:778: warning: instance variable @reload_plugins not
initialized
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:778: warning: instance variable @reload_plugins not
initialized
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:778: warning: instance variable @reload_plugins not
initialized
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:778: warning: instance variable @reload_plugins not
initialized
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:778: warning: instance variable @reload_plugins not
initialized
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:778: warning: instance variable @reload_plugins not
initialized
/Users/kurtsnyder/code/products1/vendor/rails/activerecord/lib/
active_record/validations.rb:381: warning: *' interpreted as argument prefix /Users/kurtsnyder/code/products1/vendor/rails/activerecord/lib/ active_record/validations.rb:29: warning: method redefined; discarding old message /Users/kurtsnyder/code/products1/vendor/rails/activerecord/lib/ active_record/dirty.rb:40: warning:*’ interpreted as argument prefix
/Users/kurtsnyder/code/products1/vendor/rails/activerecord/lib/
active_record/callbacks.rb:228: warning: *' interpreted as argument prefix /Users/kurtsnyder/code/products1/vendor/rails/actionpack/lib/ action_controller/routing/routing_ext.rb:2: warning: method redefined; discarding old to_param /Users/kurtsnyder/code/products1/vendor/rails/actionpack/lib/ action_controller/routing/recognition_optimisation.rb:55: warning: method redefined; discarding old recognize_path /Users/kurtsnyder/code/products1/vendor/rails/actionpack/lib/ action_controller/middleware_stack.rb:84: warning: given block not used /Users/kurtsnyder/code/products1/config/../vendor/rails/railties/lib/ initializer.rb:306: warning: global variable$gems_rake_task’ not
initialized
/Users/kurtsnyder/code/products1/config/…/vendor/rails/railties/lib/
initializer.rb:306: warning: global variable `$gems_rake_task’ not
initialized
/Users/kurtsnyder/code/products1/vendor/rails/activerecord/lib/
active_record/observer.rb:35: warning: instance variable @observers
not initialized
/Users/kurtsnyder/code/products1/vendor/rails/activerecord/lib/
active_record/observer.rb:35: warning: instance variable @observers
not initialized
** Execute db:migrate
** Invoke db:schema:dump (first_time)
** Invoke environment
** Execute db:schema:dump

On Mar 9, 5:53 pm, Kurt [email protected] wrote:

Hi – I’m upgrading an app from Rails 2.0.2 to 2.3.5 in development on
a Mac OS/X Leopard. I unfroze the old Rails files, froze the 2.3.5
gem on the machine into the app, and some quick tests of the app
showed no problems.

did you run rake rails:update ?

Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs