Db:migrate error

Hi,

I am getting below error while running rake command.

rake aborted!
no such file to load – /app/helpers/excel_helper

D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_suppo
rt/dependencies.rb:156:in require' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_suppo rt/dependencies.rb:156:inrequire’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_suppo
rt/dependencies.rb:521:in new_constants_in' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_suppo rt/dependencies.rb:156:inrequire’
./db/migrate//20110113033318_add_checklist_data.rb:1
./db/migrate//20110113033318_add_checklist_data.rb:145:in load' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_suppo rt/dependencies.rb:145:inload_with_new_constant_marking’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_suppo
rt/dependencies.rb:521:in new_constants_in' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_suppo rt/dependencies.rb:145:inload_with_new_constant_marking’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record
/migration.rb:373:in load_migration' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record /migration.rb:369:inmigration’
D:1:in migrate' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record /migration.rb:491:inmigrate’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record
/migration.rb:565:in call' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record /migration.rb:565:inddl_transaction’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record
/connection_adapters/abstract/database_statements.rb:136:in
transaction' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record /transactions.rb:182:intransaction’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record
/migration.rb:565:in ddl_transaction' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record /migration.rb:490:inmigrate’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record
/migration.rb:477:in each' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record /migration.rb:477:inmigrate’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record
/migration.rb:401:in up' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/activerecord-2.3.8/lib/active_record /migration.rb:383:inmigrate’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/tasks/databases.rake
:112
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:205:in
call' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:205:inexecute’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:200:in
each' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:200:inexecute’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:158:in
invoke_with_call_chain' D:/jruby/jruby-1.5.0/lib/ruby/1.8/monitor.rb:191:inmon_synchronize’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in
invoke_with_call_chain' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:144:ininvoke’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb
:116:in invoke_task' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb :94:intop_level’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb
:94:in each' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb :94:intop_level’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb
:133:in standard_exception_handling' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb :88:intop_level’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb
:66:in run' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb :133:instandard_exception_handling’
D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb
:63:in run' D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/bin/rake:33 D:/jruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/rake-0.9.2.2/bin/rake:19:inload’
D:\jruby\jruby-1.5.0\bin\rake:19
Tasks: TOP => db:migrate

please help me, do i am missing any support gem for this?.

Veerendra -

the error message says that a specific file is missing:

app/helpers/excel_helper[.rb]

Is there any such file in your project?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs