DateBox


#1

I have installed DateBox but now ActionMailer can not send emails. I get
an error that says “wrong number of arguments”. I read somewhere that
the latest version of Rails Engines interferes with ActionMailer. It
worked fine before I installed Rails Engines. Does anyone have any
suugestions?


#2

Ted Battreall wrote:

I have installed DateBox but now ActionMailer can not send emails. I get
an error that says “wrong number of arguments”. I read somewhere that
the latest version of Rails Engines interferes with ActionMailer. It
worked fine before I installed Rails Engines. Does anyone have any
suugestions?

Here is the error:
ArgumentError in PeopleController#sendtest
wrong number of arguments (1 for 2)

Here is the Trace:

(eval):3:in initialize_template_class' (eval):3:inrender_message’
#{RAILS_ROOT}/vendor/plugins/engines/lib/engines/action_mailer_extensions.rb:57:in
create!' #{RAILS_ROOT}/vendor/rails/actionmailer/lib/action_mailer/base.rb:267:ininitialize’
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in new' #{RAILS_ROOT}/vendor/rails/actionmailer/lib/action_mailer/base.rb:227:inmethod_missing’
#{RAILS_ROOT}/app/controllers/people_controller.rb:8:in `sendtest’


#3

Ted Battreall wrote:

Ted Battreall wrote:

I have installed DateBox but now ActionMailer can not send emails. I get
an error that says “wrong number of arguments”. I read somewhere that
the latest version of Rails Engines interferes with ActionMailer. It
worked fine before I installed Rails Engines. Does anyone have any
suugestions?

Here is the error:
ArgumentError in PeopleController#sendtest
wrong number of arguments (1 for 2)

Here is the Trace:

(eval):3:in initialize_template_class' (eval):3:inrender_message’
#{RAILS_ROOT}/vendor/plugins/engines/lib/engines/action_mailer_extensions.rb:57:in
create!' #{RAILS_ROOT}/vendor/rails/actionmailer/lib/action_mailer/base.rb:267:ininitialize’
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in new' #{RAILS_ROOT}/vendor/rails/actionmailer/lib/action_mailer/base.rb:227:inmethod_missing’
#{RAILS_ROOT}/app/controllers/people_controller.rb:8:in `sendtest’

I solved the problem with a crude workaround. Since I am only using
Datebox (which has no email features) I just cleared the contents of
“/vendor/plugins/engines/lib/engines/action_mailer_extensions.rb”. But
hopefully the Rails Engine team will fix this so it works with Rails
1.1.


#4

If you could file a ticket on the engines issue-tracking site, with as
much information (Rails/Ruby/engines versions, stack traces and so
on), we’ll get on it.

  • james