Débutant : installation de win32-open3, gem et nmake

Bonjour,

Je débute sous Ruby et en programmation.
Je cherche à scripter la génération de fichiers images, comme ce qui est
réalisé ici :
http://www.chadwickwood.com/2009/03/batch-image-resizing-with-ruby-and-imagemagick

Mais l’installation via gem de win32-open3 plante car visiblement il me
manque un outil appelé nmake.
Les seuls info que je trouve sur le web concerne Visual C++.

Faut-il que j’installe Visual C++ pour disposer de nmake ?
Puis-je obtenir l’outil autrement ?

Merci d’avance pour votre aide.

environnement:
windows pro SP3
ruby 1.8.7

Jette un oeil là -dessus avant toute chose :
http://rubyinstaller.org/

Si tu as installé ruby d’une autre façon, essaye celle-ci elle devrait
grandement te simplifier la vie.

Maintenant je ne suis pas un expert en windows (ni en ruby sous windows)
donc avis aux masochi… aux développeurs sous windows pour une réponse
plus
précise.

Michel B.

2009/10/21 Alain ***** [email protected]

Michel B. wrote:

Jette un oeil là -dessus avant toute chose :
http://rubyinstaller.org/

Si tu as installé ruby d’une autre façon, essaye celle-ci elle devrait
grandement te simplifier la vie.

Maintenant je ne suis pas un expert en windows (ni en ruby sous windows)
donc avis aux masochi… aux développeurs sous windows pour une réponse
plus
précise.

Michel B.

2009/10/21 Alain ***** [email protected]

Merci Michel.

J’ai essayé d’installer Visula C++; après redémarrage nmake n’est pas
reconnu alors que je le trouve dans le répertoire Visual C.

Du coup, j’ai retenté une install gem avec une autre gem : win32-open3
3… (x86-mswin32-60)
et là ça passe
sous irb :

require “win32/open3”
=>true

donc je suppose que c’est opérationnel. Je vais pouvoir coder.

Je ne comprends pas les détails, mais cela fonctionne. Avis aux
débutants (francophones).

Alain

Y a rien de magique là dessous.

C’est tout simplement que lorsque la gem possède un module à compiler,
il arrive que le mainteneur propose une version de la gem
précompiléepour windows en plus des gems “source”. Donc dans le cas où vous
n’avez pas d’environnement de développement correctement installé sur
votre Windows, choisissez ces gems en priorité…

Nicolas.

Le 21 octobre 2009 12:49, Alain ***** [email protected] a
écrit :

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs