Cygwin compile of 3.7.8

Has anyone had any luck compiling the latest 3.7.8 on cygwin? I’m
running
into the following:

[ 14%] Built target pygen_python_volk_modtool_95e3e
[ 14%] Built target pmt_generated
[ 15%] Built target gnuradio-pmt
Scanning dependencies of target gnuradio-runtime
[ 15%] Building CXX object
gnuradio-runtime/lib/CMakeFiles/gnuradio-runtime.dir/thread/thread.cc.o
/home/matt/src/gnuradio-3.7.8/gnuradio-runtime/lib/thread/thread.cc:245:23:
fatal error: sys/prctl.h: No such file or directory
#include <sys/prctl.h>
^
compilation terminated.

I don’t believe sys/prctl.h exists in cygwin (or even all flavors of
unix). Am I missing something obvious?

I got it compiled (if anyone is interested) with the attached rough
patch.
Here are the steps I took:

compile latest Cheetah

wget
https://pypi.python.org/packages/source/C/Cheetah/Cheetah-2.4.4.tar.gz
tar -zxf Cheetah-2.4.4.tar.gz
cd Cheetah-2.4.4
python setup.py build
python setup.py install

compile gnuradio

GNUR=gnuradio-3.7.8
wget http://gnuradio.org/releases/gnuradio/$GNUR.tar.gz
tar -zxf $GNUR.tar.gz

apply patch

[ -d $GNUR/build ] || mkdir $GNUR/build
cd $GNUR/build

cmake
-DENABLE_DEFAULT=False
-DENABLE_VOLK=True
-DENABLE_GNURADIO_RUNTIME=True
-DENABLE_GR_BLOCKS=True
-DENABLE_GR_FFT=True
-DENABLE_GR_FILTER=True
-DENABLE_GR_ANALOG=True
-DENABLE_GR_AUDIO=True
-DENABLE_GR_CHANNELS=True
-DENABLE_GR_CTRLPORT=True
-DENABLE_GR_DIGITAL=True
-DENABLE_GR_FCD=False
-DENABLE_GR_FEC=True
-DENABLE_GR_NOAA=True
-DENABLE_GR_PAGER=True
-DENABLE_GR_VOCODER=True
-DENABLE_GR_WAVELET=True
-DENABLE_GR_UTILS=True
-DENABLE_GRC=True
-DENABLE_GR_DTV=True
-DENABLE_GR_ATSC=True
-DENABLE_GR_VIDEO_SDL=True
-DENABLE_PYTHON=True

make
make install
export PYTHONPATH=/usr/local/lib/python2.7/site-packages
gnuradio-companion

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs