Current optimum app versions?


#1

What is the optimum match for Ruby, Rails, etc. for use with Radiant v.
0.6.9? Does is play well with the latest stable releases of Rails and
Ruby
(2.2.2 & 1.8.7) or are there issues with running the up to date
releases?
Just curious.

Thanks,

Nate


#2

Radiant maintains its own version of Rails in vendor/rails
As of 0.6.9 I believe it was rails 2.0.1 (with some patches)

If your are concerned about your installed gems, you need not worry.
You could even uninstall your Rails gem an Radiant would run fine. Are
you attempting to update an instance to a newer version of Rails?
0.6.9 is NOT compatible with Ruby 1.8.7
http://radiantcms.org/blog/archives/2008/06/18/ruby-1-8-7-breaks-radiant/


#3

Nate T. wrote:

What is the optimum match for Ruby, Rails, etc. for use with Radiant v.
0.6.9? Does is play well with the latest stable releases of Rails and Ruby
(2.2.2 & 1.8.7) or are there issues with running the up to date releases?
Just curious.

I believe it is Rails 2.1 and Ruby 1.8.6. But, I think Rails doesn’t
matter since a copy of Rails is included with Radiant. When deploying
you could also freeze it so that there’s no confusion.

So, the short answer is Ruby 1.8.6 - I think Ruby 1.8.7 support (aka
Rails 2.2 in our context) is ongoing!

Cheers,
Mohit.
12/2/2008 | 11:38 PM.