CSV File

Hello, I have nginx as reverse proxy to server with IIS. The server
have files .cvs. When trying to download any file the server asks for my
username / password but if you put the correct data always reapplies the
user and password and can not download the file. Their configuration is
very basic i have hope to improve it little by little.

any suggestions to solve the problem?
Thanks.

the sites-enabled/default file is:

server {
listen 80;
server_name www.xxxxxxxx.com;

    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
            root   /var/www/nginx-default;
    }

         location / {
            proxy_pass   http://Dir.to.IIS.server;
            include      /etc/nginx/conf.d/proxy.conf;
            index  index.html index.htm;
    }

}

The proxy.conf:

proxy_redirect off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
client_max_body_size 10m;
client_body_buffer_size 128k;
proxy_connect_timeout 90;
proxy_send_timeout 90;
proxy_read_timeout 90;
proxy_buffer_size 16k;
proxy_buffers 32 16k;
proxy_busy_buffers_size 64k;

the nginx.conf file:

user www-data;
worker_processes 1;

error_log /var/log/nginx/error.log;
pid /var/run/nginx.pid;

events {
worker_connections 1024;
}

http {
include /etc/nginx/mime.types;
default_type application/octet-stream;

access_log  /var/log/nginx/access.log;

sendfile        on;

keepalive_timeout  65;
tcp_nodelay        on;

gzip  on;

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;

}

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,66963,66963#msg-66963

thefix ha scritto:

Hello, I have nginx as reverse proxy to server with IIS. The server have files .cvs. When trying to download any file the server asks for my username / password but if you put the correct data always reapplies the user and password and can not download the file. Their configuration is very basic i have hope to improve it little by little.

any suggestions to solve the problem?

If you are using Integrated Windows Authentication, I suspect that it
can not be solved.

Integrated Windows Authentication does not work over HTTP Proxy
http://en.wikipedia.org/wiki/Integrated_Windows_Authentication
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/523ae943-5e6a-4200-9103-9808baa00157.mspx?mfr=true

I have read, however, that it do works using Apache (or some other HTTP
proxy, I do not remember).

[…]

Regards Manlio

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs