Creando mi primer proyecto


#1

Buenas noches a todos:
Estoy intentando crear un proyecto con Rails y cuando ejecuto el
comando:
$ rails platror
me salen estos errores o warnings:
/usr/lib/ruby/1.8/xmlsimple.rb:275: warning: already initialized
constant KNOWN_OPTIONS
/usr/lib/ruby/1.8/xmlsimple.rb:280: warning: already initialized
constant DEF_KEY_ATTRIBUTES
/usr/lib/ruby/1.8/xmlsimple.rb:281: warning: already initialized
constant DEF_ROOT_NAME
/usr/lib/ruby/1.8/xmlsimple.rb:282: warning: already initialized
constant DEF_CONTENT_KEY
/usr/lib/ruby/1.8/xmlsimple.rb:283: warning: already initialized
constant DEF_XML_DECLARATION
/usr/lib/ruby/1.8/xmlsimple.rb:284: warning: already initialized
constant DEF_ANONYMOUS_TAG
/usr/lib/ruby/1.8/xmlsimple.rb:285: warning: already initialized
constant DEF_FORCE_ARRAY
/usr/lib/ruby/1.8/xmlsimple.rb:286: warning: already initialized
constant DEF_INDENTATION
/usr/lib/ruby/1.8/xmlsimple.rb:287: warning: already initialized
constant DEF_KEY_TO_SYMBOL

¿Es algún tipo de error? ¿Algo mal en mi instalación?


#2

Mirate este enlace a ver si te soluciona algo:

http://www.unwin.org/ruby_on_rails/tips/xml_simple_already_initialized_constant_warnings.html

Reynier Pérez Mira wrote:

Buenas noches a todos:
Estoy intentando crear un proyecto con Rails y cuando ejecuto el
comando:
$ rails platror
me salen estos errores o warnings:
/usr/lib/ruby/1.8/xmlsimple.rb:275: warning: already initialized
constant KNOWN_OPTIONS

¿Es algún tipo de error? ¿Algo mal en mi instalación?


#3

On Fri, 2008-12-19 at 09:39 +0100, Jose Antonio P. wrote:

Mirate este enlace a ver si te soluciona algo:

http://www.unwin.org/ruby_on_rails/tips/xml_simple_already_initialized_constant_warnings.html

Hmmm no uso la gema flickr ni nada parecido, simplemente he creado el
proyecto usando el comando rails. He aquí un listado del comand: gem
list

*** LOCAL GEMS ***
actionmailer (2.1.2)
actionpack (2.1.2)
activerecord (2.1.2)
activeresource (2.1.2)
activesupport (2.1.2)
fastthread (1.0.1)
postgres (0.7.9.2008.01.28)
rails (2.1.2)
rake (0.8.3)


#4

Instalastes passenger al fin como te dijimos??? De seguro no hbras
instalado otra cosa mas aparte de esto… veo que tienes fastthread sin
embargo no veo rack que lo requiere tambien…

Perdona el tropelaje de la escritura pero es que toi “gorracho” … hoy
celebramos el dia del Educador aca…

Saludos Hacker (RPM)


Visite nuestra web en Internet
http://www.ispvc.rimed.cu
“50 Años de Educación en
Revolución”

XI Encuentro Internacional de Economistas sobre Globalización y Problemas
del Desarrollo 2 al 6 de marzo de 2009
http://www.anec.cu/