Could not find a valid gem 'xxx' in any repository


#1

I am attempting to install Ruby/Rails on an Windows XP box.
After following these instructions -
(http://pragmaticstudio.com/blog/2010/9/23/install-rails-ruby-windows)
including the comments at the bottom about Devkit.

I get an error when trying to do a ‘gem install sqlite3-ruby’.
The reply is ‘Could not find a valid gem ‘sqlite3-ruby’ <>=0> in any
repository.’

Any instructions on what I did wrong would be great.

Thanks!


#2

On Nov 11, 5:03pm, Carl J. removed_email_address@domain.invalid wrote:

Most likely you’re behind a proxy and you are not aware of.

Please check your browser settings. take note of the HTTP proxy
information and then use the --http-proxy option of gem install
command.

More details in the syntax use “gem help install”

Also, you can see if your proxy is not blocking S3/CDN downloads by
manually downloading in the browser one gem from rubygems.org:

http://rubygems.org/

HTH,

Luis L.


#3

Using a browser I can download gems from http://rubygems.org.
Does this mean I should NOT have to use the --http_proxy switch on the
command line?

Luis L. wrote in post #960804:

On Nov 11, 5:03pm, Carl J. removed_email_address@domain.invalid wrote:

Most likely you’re behind a proxy and you are not aware of.

Please check your browser settings. take note of the HTTP proxy
information and then use the --http-proxy option of gem install
command.

More details in the syntax use “gem help install”

Also, you can see if your proxy is not blocking S3/CDN downloads by
manually downloading in the browser one gem from rubygems.org:

http://rubygems.org/

HTH,

Luis L.


#4

On Nov 11, 7:25pm, Carl J. removed_email_address@domain.invalid wrote:

Using a browser I can download gems fromhttp://rubygems.org.
Does this mean I should NOT have to use the --http_proxy switch on the
command line?

No, you should use --http-proxy option, please check your browser
options about proxy connection and use that information in the --http-
proxy option

You will end with something like this:

gem install xxx --http-proxy=http://user:password@server


Luis L.


#5

No, you should use --http-proxy option, please check your browser
options about proxy connection and use that information in the --http-
proxy option

You will end with something like this:

gem install xxx --http-proxy=http://user:password@server


Luis L.

I understand now - thanks for your help. It is working like a charm. :slight_smile: