Could not find a valid gem 'rails' (>= 0) in any repository

#1

Dear Friend’s

                 Could not find a valid gem 'rails' (>= 0) in any 

repository

These is the error which i am facing while i am invoking the gem
install rails command.

my gem version is

gem -v

1.3.7

My Ruby Version is

ruby -v

ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]

When i am invoking gem install rails the following lines are displayed

WARNING: RubyGems 1.2+ index not found for:

RubyGems will revert to legacy indexes degrading performance.
Updating metadata for 1 gems from http://rubygems.org/
.
complete
ERROR: Could not find a valid gem ‘rails’ (>= 0) in any repository

I am using airtel Mobile office as internet whether it may be a
problem pls guide me

Please help me out friends .


Regard’s
R.K.Sakthi Raam

#2

I get the same error with ruby 1.9.2-rc2

On Jun 10, 10:05 am, Sakthi Raam Krishna Kumar

#3

I solved it by running ‘gem install rails --pre’
instead of ‘gem install rails --prerelease’.

can someone update rails release notes?
http://guides.rails.info/3_0_release_notes.html

(unless there is more updated docs somewhere)