Correctly installing UHD in Fedora 14 64-bit

Hi all,

Has anyone managed to get gnuradio working correctly with the UHD driver
on
64-bit Fedora 14. I have installed UHD (correctly I assume) in my 64-bit
Fedora 14 box, but configure cannot detect it for some reason.

I made sure that the path to libuhd.so was included in ldconfig path.
In
fedora 14 I did:
updatedb &
locate libuhd.so
then put the path from the locate command in:
vim /etc/ld.so.conf.d/uhd.conf

After that I ran ldconfig and tried the usual ./configure in gnuradio,
but
it says gr-uhd will not be built and when I check further, I find:

checking for UHD… no
gr-uhd requires libuhd 2.x.x
Not building component gr-uhd.

For some reason UHD cannot be detected.

Any ideas for a solution are welcome.

Nick

On 03/04/2011 06:02 AM, Nick O. wrote:

then put the path from the locate command in:

Its needs to find the pc file: Did you?
http://code.ettus.com/redmine/ettus/projects/uhd/wiki#Gnuradio-UHD

Also, current uhd master and gnuradio next are 3.x.x, so gnuradio next
is a bit stale?

-josh

Oops! My bad :slight_smile:

On 04/03/2011 12:53 PM, Nick O. wrote:

Oops! My bad :slight_smile:

So, I put together a script, build-gnuradio

http://www.sbrac.org/files/build-gnuradio

That will build+install+post-install-stuff Gnu Radio + UHD from the
public GIT repos, including installing the prerequisites for recent
Fedora and Ubuntu
distributions.

It might be useful for people just starting out who want to get the
latest stuff built and installed with less hassle. It has worked
reasonably well
for the few people I’ve handed it out to, you mileage may vary, etc,
etc.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs