Connection refused on Windows XP


#1

I’m trying to get rails setup on a windows XP SP2 box. I can see the
pages
when I run webrick ok. I can use
mysql Ver 14.7 Distrib 4.1.15, for Win32 (ia32)
to create the tables, but when I try to run my ruby program to
populate them I get

#<Errno::ECONNREFUSED: Connection refused - connect(2)>

and I know the username, host, and port are being picked up ok
because I have

$ diff -u
activerecord-1.13.0/lib/active_record/vendor/mysql411.rb{.orig,}
— activerecord-1.13.0/lib/active_record/vendor/mysql411.rb.orig
2005-12-
05 16:11:56.796875000 +0000
+++ activerecord-1.13.0/lib/active_record/vendor/mysql411.rb
2005-12-06 15:00
:19.765625000 +0000
@@ -44,7 +44,11 @@
@host_info = Error::err( Error::CR_LOCALHOST_CONNECTION )
@unix_socket = unix_socket
else

  •  sock = TCPSocket::new(host, 
    

port||ENV[“MYSQL_TCP_PORT”]||(Socket::getservbyname(“mysql”,“tcp”)
rescue MYSQL_PORT))

  •  begin
    
  •    sock = TCPSocket::new(host, 
    

port||ENV[“MYSQL_TCP_PORT”]||(Socket::getservbyname(“mysql”,“tcp”)
rescue MYSQL_PORT))

  •  rescue Exception => e
    
  •    raise "In real_connect(#{host}, #{user}, #{passwd}, #{db}, 
    

#{port}, #{s
ocket}, #{flag}): #{e.inspect}"

  •  end
     @host_info = sprintf Error::err(Error::CR_TCP_CONNECTION), host
    
    end

A web search has so far turned up nothing about this. I’m using rails
under cygwin with the windows (not cygwin) mysql. Has anyone seen
anything
like this before, please?

    Thank you,
    Hugh

#2

On Tue, 6 Dec 2005, Hugh S. wrote:

to create the tables, but when I try to run my ruby program to
populate them I get

#<Errno::ECONNREFUSED: Connection refused - connect(2)>

and I know the username, host, and port are being picked up ok
because I have

I find I’d passed in the wrong port. Only on the k’th time of
looking, for large values of k…

Apologies for the noise.
Hugh