Configuring Textmate for Ruby 1.9.1

I had just installed Ruby 1.9.1 using MacPorts, but TextMate still
interprets Ruby 1.8.6.

I had gone into my Shell Variables under preferences and set the
following:

Variable: TM_RUBY
Path: ./opt/local/bin/ruby1.9 (install location of my Ruby 1.9.1
install).

I ran a program, it ran on Ruby 1.9.1. I un-checked the Shell Variable
preference; it ran on Ruby 1.8.6. I checked the setting and re-ran, got
a “Command Error at line 6” pointing to some file in /tmp.

Is this configured properly? If so, what’s wrong?

If it’s not, what’s the proper configuration?

On Aug 12, 2009, at 9:41 AM, Mike A. wrote:

I ran a program, it ran on Ruby 1.9.1. I un-checked the Shell Variable
preference; it ran on Ruby 1.8.6. I checked the setting and re-ran,
got
a “Command Error at line 6” pointing to some file in /tmp.

I just ran through these steps and everything worked fine for me.

The error you show comes from where TextMate first invokes TM_RUBY.
Are you sure you just checked and un-checked the box? If you edited
the contents, you may have made it invalid with an extra quote or
something. Just a thought.

Is this configured properly? If so, what’s wrong?

If it’s not, what’s the proper configuration?

You are doing it right, yes.

James Edward G. II

After the error appeared, I had edited the directory location, taking
out the ./ at the start. The error still appeared (though it seemed to
point to a different file in /tmp). I changed it back, same error
(again, different file in /tmp).

Should I just re-create the shell variable?

Actually, no. I’m at work now (on a PC) and the Mac’s at home.

James G. wrote:

On Aug 12, 2009, at 10:26 AM, Mike A. wrote:

After the error appeared, I had edited the directory location, taking
out the ./ at the start. The error still appeared (though it seemed to
point to a different file in /tmp). I changed it back, same error
(again, different file in /tmp).

Should I just re-create the shell variable?

Can you show me the contents that variable holds now, while it’s
failing?

James Edward G. II

On Aug 12, 2009, at 10:34 AM, Mike A. wrote:

Actually, no. I’m at work now (on a PC) and the Mac’s at home.

Tonight, or whenever it’s convenient, is fine. :slight_smile:

James Edward G. II

Alright, here’s the error I (still) get:

/tmp/temp_textmate.dLXXwJ: line 6: : command not found

My setting is as follows:

Variable: TM_RUBY
Value: ./opt/local/bin/ruby1.9

On Aug 12, 2009, at 10:26 AM, Mike A. wrote:

After the error appeared, I had edited the directory location, taking
out the ./ at the start. The error still appeared (though it seemed to
point to a different file in /tmp). I changed it back, same error
(again, different file in /tmp).

Should I just re-create the shell variable?

Can you show me the contents that variable holds now, while it’s
failing?

James Edward G. II

On Aug 12, 2009, at 7:50 PM, Mike A. wrote:

Alright, here’s the error I (still) get:

/tmp/temp_textmate.dLXXwJ: line 6: : command not found

My setting is as follows:

Variable: TM_RUBY
Value: ./opt/local/bin/ruby1.9

. in a Unix path means “current directory” and that’s not what you
meant here. Try removing it and I suspect it will work just fine.

James Edward G. II

That worked. Thanks James.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs