Configuring ORACLE db to rails?

hi everyone i’m newer to ruby on rails…for the past few days i used
default sqlite db with rails and now im in the situation to use ORACLE
db in my upcoming application…can anybody give some suggestions that
what are the tools needed to configure oracle with rails
environment…step by step manner.

~Thanks in advance

Dheeraj K.

Try adding ruby-oci8 before activerecord-oracle_enhanced-adapter in the
gem file. Also, I guess you’ll be fine with the basic package, but I
haven’t worked with oracle databases, so play around.

Dheeraj K.

i have tried to connect oracle by doing the procedures mentioned as
per in the above url
and here it is my gem
gem ‘activerecord-oracle_enhanced-adapter’, ‘~> 1.4.0’
gem ‘ruby-oci8’, ‘~> 2.1.0’
in that procedure they said to install oracle instant client there it
has lot of files as below
Instant Client Package - Basic: All files required to run OCI, OCCI,
and JDBC-OCI applications (51,149,941 bytes)

*Instant Client Package - Basic Lite: Smaller version of the Basic,
with only English error messages and Unicode, ASCII, and Western
European character set support (20,043,020 bytes)

*Instant Client Package - JDBC Supplement: Additional support for XA,
Internationalization, and RowSet operations under JDBC (1,565,746 bytes)

Instant Client Package - SQLPlus: Additional libraries and
executable for running SQL*Plus with Instant Client instantclient- (759,693 bytes)

*Instant Client Package - SDK: Additional header files and an example
makefile for developing Oracle applications with Instant Client (1,110,835 bytes)

*Instant Client Package - ODBC: Additional libraries for enabling ODBC
applications (740,177 bytes)

*Instant Client Package - WRC: Workload Replay Client used to replay
workload for RAT’s DB Replay Feature instantclient-tools- (12,534 bytes)

whether i have to download all those files???
but without those files when i try to connect oracle it shows

activerecord oracle_enhanced adapter could not load ruby-oci8
library…please install ruby-oci8 gem
i have used bundle install and bundle update too… but it doesnt

I suggest you install the following packages from Oracle. Then use the
SQLPlus to verify that the Oracle libraries you need are installed and
available to your user AND that you are able to connect to the Oracle
database with the username and password you have been given. Once you
connected successfully from the command line, then work on getting
working - and then the ActiveRecord adapter working