Configuring Notification SMTP


#1

Hi,
I would like to get an email any time a comment is posted. I did the
following but it doesn’t work:

  • Started sendmail on the same box. I know it works because I use
    Mantis bug tracker which sends emails fine.
  • Moved config/mail.yml.example to config/mail.yml
  • Updated mail.yml to:
    method: :smtp
    settings:
    :address: localhost
    :port: 25
    :domain: mydomain.com
    :authentication: :login
    :user_name:
    :password:
  • In the typo admin console, set my email address in Settings ->
    Feedback -> Notification

No errors in log/production.log

Thanks,


#2

but you are using :smtp
not
:sendmail

which you said you started, perhaps you don’t have smtp working?

is anything listening on port 25?

netstat -f inet -an |grep LISTEN


#3

Hi Linda,
Thanks for the quick response. I’m not sure what you mean. I have a
local SMTP server running as a relay:

[/]$ netstat -an | grep 25
tcp 0 0 127.0.0.1:25 0.0.0.0:*
LISTEN

This server works fine to send mail from other applications on the same
box.

I tried changing it method to :sendmail but no beans.

Is there an error reported somewhere? I’m doing tail -f on
production.log and I don’t see anything. Should I turn debugging on?

Thanks


#4

eydelber z wrote:

I tried changing it method to :sendmail but no beans.

Is there an error reported somewhere? I’m doing tail -f on
production.log and I don’t see anything. Should I turn debugging on?

No, She says using sendmail method in your mail.yml

method: :sendmail

By default, if no mail.yml file in your config file, Typo use is method.


Cyril M.
http://blog.shingara.fr


#5

eydelber wrote:

Hi, as I mentioned, I already tried method sendmail with no luck:

Sorry

You know that only when it’s ham or ham? comment that send mail ?


Cyril M.
http://blog.shingara.fr


#6

You know that only when it’s ham or ham? comment that send mail ?

That’s a good point, I’m not sure what the expected behavior is.
Basically I
want an email any time somebody posts a comment (because I moderate
them, so
I want to know so I can log in and check) … even if it is spam. Is
this
supported in typo?

What I’m confused about is that I don’t see any errors in any logs…

Thanks


#7

I tried changing it method to :sendmail but no beans.

No, She says using sendmail method in your mail.yml

method: :sendmail

Hi, as I mentioned, I already tried method sendmail with no luck:

$ cat mail.yml
method: :sendmail
settings:
:address: localhost
:port: 25
:domain: mydomain.com
:authentication: :login
:user_name:
:password:

Thanks


#8

next release (maybe sunday). But we’ll think about it for the 5.2.1
release.

Cheers,
Frédéric

Hi, thanks. So there’s no way to get emails when spam comes in? Can I
mark
all comments by default as ham?
Thanks


#9

Le 9 janv. 09 à 18:33, eydelber a écrit :

What I’m confused about is that I don’t see any errors in any logs…

Thanks

The current behavior is :

  • Without moderation :
    –> probably ham : mail
    –> ham : mail
    –> probably spam : no mail
    –> spam : no mail

  • With moderation :
    –> Before moderation : no mail
    –> After moderation :
    –> ham : mail
    –> spam : no mail

Moderation was added pretty quickly because I needed it on my blog,
without thinking about side effects like the need of notification.
Maybe we should send a mail every 10 probably ham comments, but this
would force us to modify comments behavior with too much impacts for
next release (maybe sunday). But we’ll think about it for the 5.2.1
release.

Cheers,
Frédéric

Frédéric de Villamil
removed_email_address@domain.invalid tel: +33 (0)6 62 19 1337
http://t37.net Typo : http://typosphere.org