Configuration not working

Hello,

I am running Nginx 1.3.0 on CentOS. It serves several domains.

Yesterday we tried to change the allowed URIs to access one folder
specific to one domain. After the config file change we tried the “nginx
-s reload”, without apparent success or errors. After this I rebooted
the server, but the restrictions are still not effective. I still can
access “www.secret.com/_abc/def/ghi/” contents from anywhere.

nginx -V output:

nginx version: nginx/1.3.0
TLS SNI support enabled
configure arguments: --prefix=/usr/share --sbin-path=/usr/sbin/nginx
–conf-path=/etc/nginx/nginx.conf
–error-log-path=/var/log/nginx/error.log
–http-log-path=/var/log/nginx/access.log
–lock-path=/var/lock/nginx.lock --pid-path=/var/run/nginx.pid
–http-client-body-temp-path=/var/lib/nginx/body
–http-fastcgi-temp-path=/var/lib/nginx/fastcgi
–http-proxy-temp-path=/var/lib/nginx/proxy
–http-scgi-temp-path=/var/lib/nginx/scgi
–http-uwsgi-temp-path=/var/lib/nginx/uwsgi --user=nginx --group=nginx
–with-ipv6 --with-file-aio --with-http_ssl_module
–with-http_realip_module --with-http_sub_module --with-http_dav_module
–with-http_gzip_static_module --with-http_stub_status_module

The complete /etc/nginx/nginx.conf file:

worker_processes 1;
events { worker_connections 1024;}
http
{
include mime.types;
default_type application/octet-stream;
sendfile on;
keepalive_timeout 65;
gzip on;
gzip_min_length 1000; # bytes
gzip_proxied expired no-cache no-store private auth;
gzip_types text/plain application/xml text/css
text/javascript application/json text/xml application/javascript;
server_tokens off;
server
{
# ?? mainly for domain www.blabla.com, usefull for
others
location /client/data/up/ { expires 720h; }
# all domains
location /css/ { expires 720h; }
location /img/ { expires 720h; }
location /js/ { expires 720h; }
location /lib/ { expires 720h; }
location /piwik/ { expires 720h; }
}
server
{
server_name www.secret.com;
#location /_abc/def/ { … }
location /_abc/def/ghi/
{
allow 123.456.654.321;
deny all;
}
}

     include /etc/nginx/conf.d/*.conf;

}
#vim: sw=4: sts=4: ts=8

I quickly read the error logs, didn’t see anything meaningful. What may
be wrong?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs