Config XLSUITE in Windows

I try to config XLSUITE in my system. I’m facing some problem i resolved
it one by one.

now im facing this error

=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.2.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
Exiting
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mongrel/tcphack.
rb:13:in listen': An operation on a socket could not be performed because the s ystem lacked sufficient buffer space or because a queue was full. - listen(2) (E rrno::ENOBUFS) from c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon grel/tcphack.rb:13:ininitialize’
from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon
grel.rb:93:in new' from c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon grel.rb:93:ininitialize’
from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon
grel/configurator.rb:139:in new' from c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon grel/configurator.rb:139:inlistener’
from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/bin/mon
grel_rails:99:in cloaker_' from c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon grel/configurator.rb:50:incall’
from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon
grel/configurator.rb:50:in initialize' ... 14 levels... from C:/Rajesh/RubySamples/xlsuite/vendor/rails/railties/lib/commands/se rver.rb:49 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inge
m_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `re
quire’
from script/server:3

please help me to resolve it. I’m a beginner in RoR.

My System Info:
OS: WindowsXP Service Pack 2
Ruby: 1.8.6
Rails: 2.3.4
MySQL Server: 5.1

Hello,

Not sure if this is going to be a double post. Anyway… did you manage
to solve this problem?

I can start XLsuite application on my Windows machine just fine. Looking
at the trace though, I don’t think it’s related to XLsuite app. Can you
boot up other Rails application just fine using your mongrel
installation?

Here is my system information for comparison:
OS: WindowsXP Service Pack 2
Ruby: ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
Rails: 2.2.2
MySQL Server: mysql Ver 14.12 Distrib 5.0.67, for Win32 (ia32)
Gem: 1.3.1
Mongrel: 1.1.5

The Rails version should not matter since XLsuite app has “rails” in
/vendor and so the application loads up using this vendorized Rails.

Regards,
Harman S.

Rajesh Kumar wrote:

I try to config XLSUITE in my system. I’m facing some problem i resolved
it one by one.

now im facing this error

=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.2.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
Exiting
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mongrel/tcphack.
rb:13:in listen': An operation on a socket could not be performed because the s ystem lacked sufficient buffer space or because a queue was full. - listen(2) (E rrno::ENOBUFS) from c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon grel/tcphack.rb:13:ininitialize’
from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon
grel.rb:93:in new' from c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon grel.rb:93:ininitialize’
from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon
grel/configurator.rb:139:in new' from c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon grel/configurator.rb:139:inlistener’
from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/bin/mon
grel_rails:99:in cloaker_' from c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon grel/configurator.rb:50:incall’
from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon
grel/configurator.rb:50:in initialize' ... 14 levels... from C:/Rajesh/RubySamples/xlsuite/vendor/rails/railties/lib/commands/se rver.rb:49 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inge
m_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `re
quire’
from script/server:3

please help me to resolve it. I’m a beginner in RoR.

My System Info:
OS: WindowsXP Service Pack 2
Ruby: 1.8.6
Rails: 2.3.4
MySQL Server: 5.1

Hmm… I’ve never seen anything like that when booting up my XLsuite.
That is very weird. Did you solve this problem?

I don’t think it’s a problem related to XLsuite app though. Can you
boot up other Rails application just fine?

Your Rails version shouldn’t matter since XLsuite has rails under /
vendor.

Here is my system info for some comparison:
OS: WindowsXP Service Pack 2
Ruby: ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
Gem: 1.3.1
MySQL: mysql Ver 14.12 Distrib 5.0.67, for Win32 (ia32)

On Sep 26, 1:30 am, Rajesh R. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs