Config issue

Im trying to set up nginx with django. This is the instruction given:

Symlink to this file from /etc/nginx/sites-enabled so nginx can see it:

 sudo ln -s ~/path/to/your/mysite/mysite_nginx.conf

/etc/nginx/sites-enabled/

The problem is this folder doesn’t exist: /etc/nginx/sites-enabled/

my only nginx folder is in “/usr/local/nginx” so i don’t know what to
do (I’m on ubuntu btw.) I’ve tried including the file it wanted me to
symlink, into my nginx.conf via an “Include” statement but everytime i
reload nginx, this Include action is causing an error.

What can i do to make nginx see my django project’s config file?

On Thu, Jan 09, 2014 at 07:03:49PM +0000, Matthew Ngaha wrote:

Hi there,

Im trying to set up nginx with django. This is the instruction given:

Symlink to this file from /etc/nginx/sites-enabled so nginx can see it:

That instruction assumes that the nginx config file that is being used
already has something like “include /etc/nginx/sites-enabled/*conf”,
so that every matching file will be processed.

Apparently that’s not true in this case.

my only nginx folder is in “/usr/local/nginx” so i don’t know what to
do (I’m on ubuntu btw.) I’ve tried including the file it wanted me to
symlink, into my nginx.conf via an “Include” statement but everytime i
reload nginx, this Include action is causing an error.

“include” is the correct directive to use.

Documentation at http://nginx.org/r/include, in case anything is
unclear.

Hopefully the words of the error will be enough to let you find how to
overcome it.

f

Francis D. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs