Config.gem dependencies broken?

Hello there,

I am having some strange problems with my project’s gem dependencies
on my staging server and really don’t know where this is coming from.

My config.gem entries in the environment.rb file are the following:

— snip —

config.gem “geonames”
config.gem “yelp”
config.gem ‘oauth’, :version => “>= 0.2.1”
config.gem “vikinggem”, :lib => “viking”
config.gem “RedCloth”, :lib => “redcloth”, :version => “>= 4.0”
config.gem ‘pager-retardase_inhibitor’, :lib =>
‘retardase_inhibitor’, :source => ‘http://gems.github.com
config.gem ‘right_aws’
config.gem ‘mime-types’, :lib => ‘mime/types’
config.gem ‘json’
config.gem ‘hpricot’
config.gem ‘uuidtools’
config.gem ‘chronic’
config.gem ‘htmlentities’

— snip —

Now when I do a gem list --local on the affected machine, it looks
like this:

*** LOCAL GEMS ***

— snip —

actionmailer (2.2.2)
actionpack (2.2.2)
activerecord (2.2.2)
activeresource (2.2.2)
activesupport (2.2.2)
capistrano (2.5.2)
chronic (0.2.3)
fastthread (1.0.1)
geonames (0.2.2)
highline (1.5.0)
hoe (1.8.2)
hpricot (0.6.164)
htmlentities (4.0.0)
image_science (1.1.3)
json (1.1.3)
mime-types (1.15)
net-scp (1.0.1)
net-sftp (2.0.1)
net-ssh (2.0.4)
net-ssh-gateway (1.0.0)
oauth (0.2.7)
pager-retardase_inhibitor (1.0.20080518)
passenger (2.0.3)
rack (0.4.0)
rails (2.2.2)
rake (0.8.3)
RedCloth (4.1.1)
right_aws (1.9.0)
right_http_connection (1.2.4)
rspec (1.1.11)
ruby-hmac (0.3.2)
ruby-openid (2.1.2)
rubyforge (1.0.1)
rubygems-update (1.3.1)
RubyInline (3.8.1)
uuidtools (1.0.4)
vikinggem (0.0.3)
yelp (0.2.1)
ZenTest (3.11.0)

— snip —

Nooow when I do a rake gems in my project’s folder, I get the
following:

— snip —

(in /var/www/project_abc/releases/20081201014151)

  • [I] geonames
  • [I] yelp
    • [I] json = 1.1.3
    • [ ] hoe = 1.8.2
    • [ ] rubyforge = 1.0.1
    • [I] rake = 0.8.3
  • [I] oauth >= 0.2.1
    • [I] ruby-hmac = 0.3.2
      • [ ] hoe = 1.8.2
      • [ ] rubyforge = 1.0.1
      • [I] rake = 0.8.3
    • [ ] hoe = 1.8.2
    • [ ] rubyforge = 1.0.1
    • [I] rake = 0.8.3
  • [I] vikinggem
  • [I] RedCloth >= 4.0
    rake aborted!
    You have a nil object when you didn’t expect it!
    The error occurred while evaluating nil.dependencies
    /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/gem_dependency.rb:
    77:in dependencies' /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:into_proc’
    /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/gem_dependency.rb:
    80:in map' /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/gem_dependency.rb: 80:independencies’
    /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/tasks/gems.rake:15:in
    print_gem_status' /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/tasks/gems.rake:4 /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/tasks/gems.rake:3:ineach’
    /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/tasks/gems.rake:3
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in call' /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:inexecute’
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in each' /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:inexecute’
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:578:in
    invoke_with_call_chain' /usr/lib/ruby/1.8/monitor.rb:242:insynchronize’
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
    invoke_with_call_chain' /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:564:ininvoke’
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2019:in
    invoke_task' /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:intop_level’
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in each' /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:intop_level’
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
    standard_exception_handling' /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1991:intop_level’
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1970:in run' /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:instandard_exception_handling’
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1967:in run' /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/bin/rake:31 /usr/bin/rake:19:inload’
    /usr/bin/rake:19

— snip —

First of all, why is it saying hoe/rubyforge is missing (as they are
listed in the gems list --local list) & secondly, why’s there a
nil.dependencies exception?

Apparently this also does break my app, since all views that rely on
acts_as_textiled throw a “ActionView::TemplateError (uninitialized
constant Err::Acts::Textiled::ClassMethods::RedCloth) …” exception.

I already did a sudo gem uninstall/clean/install of all gems… no
change :-/

[email protected]:~$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux]
[email protected]:~$ rails -v
Rails 2.2.2

Hrm. Any ideas? Suggestions? I am seriously kinda lost here…

Thanks,
-Joerg

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs