Components needed for Ezcap EzTV dongle

Once again, thank you for reading this.

Installing the UHD library was painless and now I want to know which
components I need to use my Ezcap EzTV dongle, when it eventually
arrives.

– ######################################################
– # Gnuradio enabled components
– ######################################################
– * testing-support
– * volk
– * doxygen
– * gruel
– * gnuradio-core
– * gr-atsc
– * gr-audio
– * gr-digital
– * gr-noaa
– * gr-pager
– * gr-qtgui
– * gr-trellis
– * gr-uhd
– * gr-video-sdl
– * gr-vocoder
– * gr-fcd
– * gr-wavelet

– ######################################################
– # Gnuradio disabled components
– ######################################################
– * python-support
– * gnuradio-companion
– * gr-comedi
– * gr-shd
– * gr-utils
– * gr-wxgui


Regards,
Phil

On 14/05/12 13:16, Andrew D. wrote:

Although they are not technically required, python-support,
gnuradio-companion, gr-utils, and gr-wxgui are almost necessary to get
anything interesting done. Also i’m not sure UHD is required for the
RTLSDR, I think it uses it’s own module ( or just write samples to
disk and process later with Gnuradio ). It all depends on what you
want to do.

Thanks Andrew,

I thought I read somewhere that UHD was required but I could very easily
be mistaken. Perhaps someone who is using on of these dongles can let me
know. Now to complete the next step.

What do I need for Python support?

What do I need for gnuradio-companion support?

What do I need for gr-utils support?

What do I need for gr-wxgui support?

I’ve installed several devel packages but evidently not the correct
ones. By the way, I’m using Mageia version 1, a fork off Mandriva.


Regards,
Phil

Although they are not technically required, python-support,
gnuradio-companion, gr-utils, and gr-wxgui are almost necessary to get
anything interesting done. Also i’m not sure UHD is required for the
RTLSDR, I think it uses it’s own module ( or just write samples to
disk and process later with Gnuradio ). It all depends on what you
want to do.

well lets start with the cmake output, post everything it says here
and lets see what up.

On Mon, May 14, 2012 at 5:43 AM, Phil [email protected] wrote:

Thanks Andrew,

What do I need for gr-wxgui support?

I’ve installed several devel packages but evidently not the correct ones. By
the way, I’m using Mageia version 1, a fork off Mandriva.

There is a build-gnuradio script which is known to work on other
RPM-based systems so maybe you can use that? It should handle all the
dependencies for a full install.
http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGR#Using-the-build-gnuradio-script

Otherwise the dependencies are listed in the wiki, but finding the
right list can be tricky. Here is one for opensuse:
http://gnuradio.org/redmine/projects/gnuradio/wiki/SuseInstall

If that’s not sufficient or complete, I know the list on this page is
good:
http://gnuradio.org/redmine/projects/gnuradio/wiki/UbuntuInstall

When you succeed maybe you can help us update this page, which seems
hopelessly out of date:
http://gnuradio.org/redmine/projects/gnuradio/wiki/MandrivaInstall

Concerning the UHD dependency, gr-osmosdr also provides a wrapper
around gr-uhd if UHD is avaialble and I think gr-baz provides some
networking tool for UHD devices, hence the dependency.

Alex

On 14/05/12 14:10, Andrew D. wrote:

well lets start with the cmake output, post everything it says here
and lets see what up.

OK Andrew here it is:

[[email protected] build]# cmake …/
– Build type not specified: defaulting to release.
– Could NOT find SWIG (missing: SWIG_EXECUTABLE SWIG_DIR)

– The build system will automatically enable all components.
– Use -DENABLE_DEFAULT=OFF to disable components by default.

– Configuring python-support support…
– Dependency PYTHONLIBS_FOUND = TRUE
– Dependency SWIG_FOUND = FALSE
– Dependency SWIG_VERSION_CHECK =
– Disabling python-support support.
– Override with -DENABLE_PYTHON=ON/OFF

– Configuring testing-support support…
– Dependency CPPUNIT_FOUND = TRUE
– Enabling testing-support support.
– Override with -DENABLE_TESTING=ON/OFF

– Configuring volk support…
– Enabling volk support.
– Override with -DENABLE_VOLK=ON/OFF
– checking for module ‘orc-0.4 > 0.4.11’
– package ‘orc-0.4 > 0.4.11’ not found
– orc files (missing: ORC_LIBRARY ORC_INCLUDE_DIR)
– 64 overruled
– orc overruled
– Available arches: generic
– Available machines: generic
– Did not find liborc and orcc, disabling orc support…
– Using install prefix: /usr/local
– TRY_SHM_VMCIRCBUF set to ON.

– Configuring doxygen support…
– Dependency DOXYGEN_FOUND = YES
– Enabling doxygen support.
– Override with -DENABLE_DOXYGEN=ON/OFF

– Configuring gruel support…
– Dependency Boost_FOUND = TRUE
– Dependency PYTHONINTERP_FOUND = TRUE
– Enabling gruel support.
– Override with -DENABLE_GRUEL=ON/OFF

– Configuring gnuradio-core support…
– Dependency ENABLE_GRUEL = ON
– Dependency ENABLE_VOLK = ON
– Dependency Boost_FOUND = TRUE
– Dependency FFTW3F_FOUND = TRUE
– Dependency PYTHONINTERP_FOUND = TRUE
– Enabling gnuradio-core support.
– Override with -DENABLE_GR_CORE=ON/OFF
– Loading build date Mon, 14 May 2012 02:52:00 into gr_constants…
– Loading version 3.6.0 into gr_constants…

– Python checking for python >= 2.5
– Python checking for python >= 2.5 - found

– Python checking for Cheetah >= 2.0.0
– Python checking for Cheetah >= 2.0.0 - found

– Python checking for lxml >= 1.3.6
– Python checking for lxml >= 1.3.6 - found

– Python checking for pygtk >= 2.10.0
– Python checking for pygtk >= 2.10.0 - found

– Python checking for numpy
– Python checking for numpy - found

– Configuring gnuradio-companion support…
– Dependency ENABLE_GR_CORE = ON
– Dependency ENABLE_PYTHON = OFF
– Dependency PYTHON_MIN_VER_FOUND = TRUE
– Dependency CHEETAH_FOUND = TRUE
– Dependency LXML_FOUND = TRUE
– Dependency PYGTK_FOUND = TRUE
– Dependency NUMPY_FOUND = TRUE
– Disabling gnuradio-companion support.
– Override with -DENABLE_GRC=ON/OFF

– Configuring gr-atsc support…
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Enabling gr-atsc support.
– Override with -DENABLE_GR_ATSC=ON/OFF

– Configuring gr-audio support…
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Enabling gr-audio support.
– Override with -DENABLE_GR_AUDIO=ON/OFF
– Found ALSA 1.0.24.1
– checking for module ‘jack’
– package ‘jack’ not found
– checking for module ‘portaudio-2.0’
– package ‘portaudio-2.0’ not found
– checking for module ‘comedilib’
– package ‘comedilib’ not found

– Configuring gr-comedi support…
– Dependency COMEDI_FOUND =
– Dependency LINUX = TRUE
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Disabling gr-comedi support.
– Override with -DENABLE_GR_COMEDI=ON/OFF

– Configuring gr-digital support…
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Enabling gr-digital support.
– Override with -DENABLE_GR_DIGITAL=ON/OFF

– Configuring gr-noaa support…
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Enabling gr-noaa support.
– Override with -DENABLE_GR_NOAA=ON/OFF

– Configuring gr-pager support…
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Enabling gr-pager support.
– Override with -DENABLE_GR_PAGER=ON/OFF
– Found Qwt: /usr/lib/libqwt.so

– Python checking for PyQt4
– Python checking for PyQt4 - found

– Configuring gr-qtgui support…
– Dependency Boost_FOUND = TRUE
– Dependency QT4_FOUND = YES
– Dependency QWT_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Dependency PYTHONLIBS_FOUND = TRUE
– Dependency PYQT4_FOUND = TRUE
– Enabling gr-qtgui support.
– Override with -DENABLE_GR_QTGUI=ON/OFF

– Configuring gr-trellis support…
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Dependency ENABLE_GR_DIGITAL = ON
– Enabling gr-trellis support.
– Override with -DENABLE_GR_TRELLIS=ON/OFF
– checking for module ‘uhd’
– package ‘uhd’ not found
– Found UHD: /usr/local/lib/libuhd.so

– Configuring gr-uhd support…
– Dependency Boost_FOUND = TRUE
– Dependency UHD_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Enabling gr-uhd support.
– Override with -DENABLE_GR_UHD=ON/OFF
– checking for module ‘shd’
– package ‘shd’ not found
– Could NOT find SHD (missing: SHD_LIBRARIES SHD_INCLUDE_DIRS)

– Configuring gr-shd support…
– Dependency Boost_FOUND = TRUE
– Dependency SHD_FOUND = FALSE
– Dependency ENABLE_GR_CORE = ON
– Disabling gr-shd support.
– Override with -DENABLE_GR_SHD=ON/OFF

– Configuring gr-utils support…
– Dependency ENABLE_GR_CORE = ON
– Dependency ENABLE_PYTHON = OFF
– Disabling gr-utils support.
– Override with -DENABLE_GR_UTILS=ON/OFF

– Configuring gr-video-sdl support…
– Dependency SDL_FOUND = YES
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Enabling gr-video-sdl support.
– Override with -DENABLE_GR_VIDEO_SDL=ON/OFF

– Configuring gr-vocoder support…
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Enabling gr-vocoder support.
– Override with -DENABLE_GR_VOCODER=ON/OFF

– Configuring gr-fcd support…
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Dependency ENABLE_GR_AUDIO = ON
– Dependency LIBUSB_FOUND = TRUE
– Enabling gr-fcd support.
– Override with -DENABLE_GR_FCD=ON/OFF

– Configuring gr-wavelet support…
– Dependency Boost_FOUND = TRUE
– Dependency ENABLE_GR_CORE = ON
– Dependency GSL_FOUND = 1
– Enabling gr-wavelet support.
– Override with -DENABLE_GR_WAVELET=ON/OFF

– Python checking for wx >= 2.8
– Python checking for wx >= 2.8 - found

– Python checking for numpy
– Python checking for numpy - found

– Configuring gr-wxgui support…
– Dependency ENABLE_GR_CORE = ON
– Dependency ENABLE_PYTHON = OFF
– Dependency NUMPY_FOUND = TRUE
– Dependency WX_FOUND = TRUE
– Disabling gr-wxgui support.
– Override with -DENABLE_GR_WXGUI=ON/OFF

– ######################################################
– # Gnuradio enabled components
– ######################################################
– * testing-support
– * volk
– * doxygen
– * gruel
– * gnuradio-core
– * gr-atsc
– * gr-audio
– * gr-digital
– * gr-noaa
– * gr-pager
– * gr-qtgui
– * gr-trellis
– * gr-uhd
– * gr-video-sdl
– * gr-vocoder
– * gr-fcd
– * gr-wavelet

– ######################################################
– # Gnuradio disabled components
– ######################################################
– * python-support
– * gnuradio-companion
– * gr-comedi
– * gr-shd
– * gr-utils
– * gr-wxgui

– Using install prefix: /usr/local
– Building for version: 3.6.0 / 3.6.0
– Configuring done
– Generating done
– Build files have been written to: /usr/local/src/gnuradio-3.6.0/build


Regards,
Phil

On 14/05/12 16:05, Alexandru C. wrote:

On Mon, May 14, 2012 at 5:43 AM, Phil[email protected]invalid wrote:

On 14/05/12 13:16, Andrew D. wrote:

There is a build-gnuradio script which is known to work on other
RPM-based systems so maybe you can use that? It should handle all the
dependencies for a full install.

http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGR#Using-the-build-gnuradio-script

Thanks Alex, I had no end of trouble with the build-gnuradio script and
I’ll have a look at the links that you have provided.


Regards,
Phil