Im trying to follow the railscasts complex forms tutorial, but im
doing it with :through realted tables and im having some problems.
Ive made a pastie of the error and related files so its easier to
read: Parked at Loopia
Any thoughts? Thanks.
Im trying to follow the railscasts complex forms tutorial, but im
doing it with :through realted tables and im having some problems.
Ive made a pastie of the error and related files so its easier to
read: Parked at Loopia
Any thoughts? Thanks.
Steven Harrison wrote:
Im trying to follow the railscasts complex forms tutorial, but im
doing it with :through realted tables and im having some problems.Ive made a pastie of the error and related files so its easier to
read: Parked at LoopiaAny thoughts? Thanks.
run ruby -c file_name
on each file to make sure they pass [I guess they do]
do a require_dependency in one of the other?
do a require_dependency in one of the other?
Thanks for your reply, but could you explain abit more please? Thanks.
On Apr 16, 6:35 pm, Roger P. [email protected]
Thanks again Roger.
Yea you were right, the problem was with the name of the join table
and model. I thought that was the naming convention, but thats
apparently for has_and_belongs_to_many, and its better to have a
meaningful singular name for the join table using :through.
Thanks again
On Apr 16, 7:39 pm, Roger P. [email protected]
Steven Harrison wrote:
do a require_dependency in one of the other?
Thanks for your reply, but could you explain abit more please? Thanks.On Apr 16, 6:35 pm, Roger P. [email protected]
ruby -c is
ruby -c app/models/orders_…
doing require_dependency
would be
at the top of one file,w here it errs, add
require_dependency ‘app/models/orders_sandwiches’
I wonder if
class OrdersSandwiches < ActiveRecord::Base
should be OrdersSandwich
though
Yea you were right, the problem was with the name of the join table
and model. I thought that was the naming convention, but thats
apparently for has_and_belongs_to_many, and its better to have a
meaningful singular name for the join table using :through.
I agree–their naming syntax is somehow lacking, in this instance
This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.
Sponsor our Newsletter | Privacy Policy | Terms of Service | Remote Ruby Jobs