Compiling ruby-1.8.6 on CentOS-4.5 with readline and openssl

I am having problems with getting a recent version of ruby properly
built and installed on my CentOS-4.5 box. I obtained the source from
ruby-lang.org and built it taking all the defaults in ./configure. I
see both openssl and readline ext being built. However, after I “make
install” ruby into /usr/local/lib|bin and try and open a console in a
rails project I get a message telling me that the required library,
“readline” is not available.

What must I do to enable this?

Sincerely,

James B. wrote:

I have discovered that running ./configure with the options
–with-readline-dir=/usr and --with-openssl-dir=/usr seems to have
solved the missing readline and openssl support problem. Now I discover
that I can no longer find my installed gems. Sigh.

So… I went to cd /usr/lib/ruby/gems/1.8/gems/rubygems-update-0.9.4
and ran ruby setup.rb. Now I have to reload all of my gems I suppose
using gem install x --include-dependencies --remote.

sigh. sigh…

problems.
Or you use checkinstall. :wink:
http://checkinstall.izto.org/

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

James B. wrote:

sigh. sigh…

I basically gave up trying to add open-source packages to RPM-based
package management systems for just this reason. Either you stay within
the repository system, or you don’t. It’s that simple. I haven’t tried
.deb-based systems recently, but the last time I did, I had similar
problems.

It’s a bit better with Gentoo, since the packaging system is designed
around source packages. The Gentoo Ruby herd is pretty active and most
gems that are at all popular – rake, rspec, rails, hpricot, etc. – are
packaged and show up in Gentoo “testing” within a few days of them
hitting the Gem repository.

If you need to stay with CentOS for some reason, at least upgrade to
CentOS 5 if you can. I forget which Ruby is there – it’s either 1.8.5
or 1.8.6. Or switch to Fedora 7 – it’s much more up to date and has
many more tested packages than CentOS or its RHEL parent.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFG3y6H8fKMegVjSM8RAvMxAJ4wiq6x1OQLsF/OtdirwpDYRgUuoQCfdVpb
hkZunr4MmjjAXpoWjUQFyFE=
=T+aR
-----END PGP SIGNATURE-----

Phil wrote:

problems.
Or you use checkinstall. :wink:
http://checkinstall.izto.org/

That bit of info was worth posting to the list regardless of my other
problems. I haven’t got it worjking yet, but I am getting closer.

Thank you.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs