Compiling nginx from sources and including xslt sources

Hi,

I’m trying to compile nginx from source but despite providing
./configure
with --with-ld-opt I can’t seem to see it.

This is the complete command I’m trying to use.

./configure --prefix=/opt/nginx-1.9.9/conf
–sbin-path=/opt/nginx-1.9.9/sbin/nginx
–conf-path=/opt/nginx-1.9.9/conf/nginx.conf
–pid-path=/opt/nginx-1.9.9/nginx.pid --loc
k-path=/opt/nginx-1.9.9/nginx.lock
–error-log-path=/opt/nginx-1.9.9/logs/error.log
–http-log-path=/opt/nginx-1.9.9/logs/access.log
–http-client-body-temp-path=/opt/nginx- 1.9.9/lib/body
–http-fastcgi-temp-path=/opt/nginx-1.9.9/lib/fastcgi
–http-proxy-temp-path=/opt/nginx-1.9.9/lib/proxy
–http-scgi-temp-path=/opt/nginx-1.9.9/lib/scgi --http
-uwsgi-temp-path=/opt/nginx-1.9.9/lib/uwsgi --user=www-data
–group=www-data
–with-debug --with-http_v2_module --with-http_gzip_static_module
–with-http_addition_module – with-http_dav_module
–with-http_realip_module --with-http_stub_status_module
–with-http_sub_module --with-ipv6 --with-mail --with-mail_ssl_module
–with-http_ssl_module – with-openssl=/opt/src/nginx/openssl-1_0_1g
–with-sha1=/opt/src/nginx/openssl-1_0_1g
–with-md5=/opt/src/nginx/openssl-1_0_1g --with-http_xslt_module
–with-pcre=/opt/src/ng inx/pcre-8.32 --with-pcre-jit
–with-zlib=/opt/src/nginx/zlib-1.2.8
–with-ld-opt="-I/opt/src/nginx/libxml-2.9.3
-I/opt/src/nginx/xslt-1.1.28"

~Thanks

Posted at Nginx Forum:
https://forum.nginx.org/read.php?2,264346,264346#msg-264346

Hello!

On Thu, Feb 04, 2016 at 10:36:38AM -0500, orglee wrote:

Hi,

I’m trying to compile nginx from source but despite providing ./configure
with --with-ld-opt I can’t seem to see it.

This is the complete command I’m trying to use.

[…]

–with-ld-opt="-I/opt/src/nginx/libxml-2.9.3
-I/opt/src/nginx/xslt-1.1.28"

The --with-ld-opt option is used when calling linker. It makes no
sense to use “-I” there. If you want to set include paths,
consider using --with-cc-opt instead.


Maxim D.
http://nginx.org/

I’m still getting:

(…)
checking for libxslt … not found
checking for libxslt in /usr/local/ … not found
checking for libxslt in /usr/pkg/ … not found
checking for libxslt in /opt/local/ … not found

./configure: error: the HTTP XSLT module requires the libxml2/libxslt
libraries. You can either do not enable the module or install the
libraries.

Posted at Nginx Forum:
https://forum.nginx.org/read.php?2,264346,264350#msg-264350

Oh ok I’m dumb. :stuck_out_tongue:

Can I somehow specify those library paths to? I really would like to
avoid
compiling them into directory structure of my current system.

Posted at Nginx Forum:
https://forum.nginx.org/read.php?2,264346,264359#msg-264359

Hello!

On Thu, Feb 04, 2016 at 12:55:43PM -0500, orglee wrote:

I’m still getting:

(…)
checking for libxslt … not found
checking for libxslt in /usr/local/ … not found
checking for libxslt in /usr/pkg/ … not found
checking for libxslt in /opt/local/ … not found

./configure: error: the HTTP XSLT module requires the libxml2/libxslt
libraries. You can either do not enable the module or install the libraries.

That’s because there are no libxml2/libxslt libraries available
via the paths you’ve specified. Note that you need libraries to
be built and installed, just a source code won’t work - nginx
doesn’t know how to compile libxml2/libxslt for you.


Maxim D.
http://nginx.org/

Hello!

On Thu, Feb 04, 2016 at 01:50:00PM -0500, orglee wrote:

Oh ok I’m dumb. :stuck_out_tongue:

Can I somehow specify those library paths to? I really would like to avoid
compiling them into directory structure of my current system.

Refer to the library docs to find out how to compile them and
install to some private location. Usually the relevant configure
option is “–prefix”.

Then use appropriate compiler and linker options to provide paths
to include files and libraries during nginx compilation.


Maxim D.
http://nginx.org/

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs