Compiling gnuradio


#1

Hi,

I am a newbie to gnuradio. To begin with, I was trying to download and
compile gnuradio. I did an svn checkout, and did bootstrap followed by
configure.
But I got the following message in configure output.

checking for Python wxWidgets wrappers >= 2.8… no
checking for Numeric Python extensions… yes
Not building component gr-wxgui.

Also I got the following output from Python when I tried to see what
configure was doing…

Python 2.6.2 (release26-maint, Apr 19 2009, 01:56:41)
[GCC 4.3.3] on linux2
Type “help”, “copyright”, “credits” or “license” for more information.

import wx
assert wx.version().split()[0] >= “2.8”
Traceback (most recent call last):
File “”, line 1, in
AttributeError: ‘module’ object has no attribute ‘version’

Could you tell me which package I need to install to get this working ?
If I understand correctly, this is needed for graphical displays of
plots etc.
I am using ubuntu jaunty. I know that I can get the prebuilt gnuradio
for ubuntu, but I wanted to compile from source and install…

Thanks,
Regards,
Hgplus


#2

On Sun, May 17, 2009 at 11:56 AM, hgplus removed_email_address@domain.invalid wrote:

I am using ubuntu jaunty. I know that I can get the prebuilt gnuradio
for ubuntu, but I wanted to compile from source and install…

Welcome!

These instructions are pretty complete:

http://gnuradio.org/trac/wiki/UbuntuInstall

Try that out and hopefully it works for you.

Good luck!

Brian


#3

Brian P. wrote:

checking for Numeric Python extensions… yes

plots etc.
Try that out and hopefully it works for you.

Good luck!

Brian

Thanks Brian… I am able to build gr-wxgui now. It turned out to be due
to some conflict between installed versions of python-wxgtk i.e 2.8
and 2.6.
I needed to uninstall 2.6 for the configure script to recognise 2.8.
Also, it seems that the prebuilt version of gnuradio was depending on
this (2.6) package and when I removed 2.6, the synaptic installed
gnuradio also got removed. Maybe this needs to be added to the wiki…

Thanks,
Warm Regards,
Harith


#4

On Sun, May 17, 2009 at 1:00 PM, hgplus removed_email_address@domain.invalid wrote:

Thanks Brian… I am able to build gr-wxgui now. It turned out to be due
to some conflict between installed versions of python-wxgtk i.e 2.8
and 2.6.
I needed to uninstall 2.6 for the configure script to recognise 2.8.
Also, it seems that the prebuilt version of gnuradio was depending on
this (2.6) package and when I removed 2.6, the synaptic installed
gnuradio also got removed. Maybe this needs to be added to the wiki…

Sounds like some good information to add to the wiki. Feel free to add
it!

Brian