Compiling gnuradio from source on GENTOO Linux failed

Hi,

I am trying to build gnuradio on a recent Gentoo system from
source. I tried to use emerge/portage for that, but it
fails in a configuration step.

The system:
Recent Gentoo Linux
gcc version 4.8.4 (Gentoo 4.8.4 p1.4, pie-0.6.1)
glibc-2.20-r2
CPU:AMD Phenom™ II X6 1090T Processor

The device I want to use as receiver is listed via ‘lsusb -v’
like this:

Bus 002 Device 004: ID 0ccd:00d3 TerraTec Electronic GmbH
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x0ccd TerraTec Electronic GmbH
idProduct 0x00d3
bcdDevice 1.00
iManufacturer 1 Realtek
iProduct 2 RTL2838UHIDIR
iSerial 3 00000001
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 34
bNumInterfaces 2
bConfigurationValue 1
iConfiguration 4 USB2.0-Bulk&Iso
bmAttributes 0x80
(Bus Powered)
MaxPower 500mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 255 Vendor Specific Protocol
iInterface 5 Bulk-In, Interface
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 1
bAlternateSetting 0
bNumEndpoints 0
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 255 Vendor Specific Protocol
iInterface 5 Bulk-In, Interface
Device Qualifier (for other device speed):
bLength 10
bDescriptorType 6
bcdUSB 2.00
bDeviceClass 0
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
bNumConfigurations 2
Device Status: 0x0000
(Bus Powered)

I downloaded gnuradio-3.7.5 and followed the
instructions on the wiki.

The build-process ended without error as far
as I can tell (buildlog attached).

Running ‘make test’ sometimes reports 2 and sometimes
3 error on the identical build (testlog attached)

If I install gnuradio nontheless and starting gnuradio-companion
it shows a dialog displaying this:


Cannot import gnuradio.

Is the python path environment variable set correctly?
All OS: PYTHONPATH

Is the library path environment variable set correctly?
Linux: LD_LIBRARY_PATH
Windows: PATH
MacOSX: DYLD_LIBRARY_PATH

and after pressing CLOSE it ends.

I set PYTHONPATH to /usr/lib64/python2.7 and
added /usr/local/lib64 to ld.so.config but that
does not change anything. Even without setting PYTHONPATH
explicitely no other python application shows problems…

I used ‘strace’ to trace the calls of gnuradio-companion
and subprocesses but found nothing which gives any further
informations to me.

I googled for the failed tests and build errors but
I either find nothing appropiate (exact searchh phrase)
or much to much (loose search phrase). The list of
open build problems seems also not to mention my case.

Since I am new to gnuradio and I am no native English speaker
I may not being /that/ successful in searching with the right
phrases…

How can I proceed from here to fix the above problems?

Thank you very much in advance for any help!

Best regards,
Meino

Dear Meino

On 12. 04. 2015 15:49, [email protected] wrote:

Linux: LD_LIBRARY_PATH
Windows: PATH
MacOSX: DYLD_LIBRARY_PATH

and after pressing CLOSE it ends.

I set PYTHONPATH to /usr/lib64/python2.7 and
added /usr/local/lib64 to ld.so.config but that
does not change anything. Even without setting PYTHONPATH
explicitely no other python application shows problems…

Like gnuradio-companion’s dialog says, this looks like Python can’t find
your GR installation.

Try running “python” and then type “import gnuradio”. You shouldn’t get
any errors if everything has been installed correctly:

$ python
Python 2.7.8 (default, Oct 18 2014, 12:50:18)
[GCC 4.9.1] on linux2
Type “help”, “copyright”, “credits” or “license” for more information.

import gnuradio

If this fails, check where GR’s Python modules got installed. Python
modules should be in a directory named “gnuradio” that has contents
similar to this:

$ ls gnuradio
init.py
init.pyc
init.pyo
analog
atsc
audio
blocks

Make sure that the directory above the “gnuradio” directory is in the
Python’s include path (paths listed in PYTHONPATH and the default
include paths for your system).

For example, if you find
“/usr/local/lib/python2.7/dist-packages/gnuradio”, try putting
“/usr/local/lib/python2.7/dist-packages” in PYTHONPATH.

Best regards
Tomaž

I know I’m super late to the party on this thread, but gentoo does have
working ebuilds which are up to date. You could just install from the
package manager.

-Zero_Chaos

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs