Compile nginx 1.4.7 --with-http_rewrite_module Error

hi:
I compiled nginx1.4.7,add to --with-pcre=/root/nginx/pcre-8.34
–with-http_rewrite_module parameter;An error occurred :./configure:
error: invalid option “–with-http_rewrite_module” ,Trouble who can talk
about what is the problem

[email protected]

On Tue, 2014-05-13 at 11:25 +0800, [email protected] wrote:

hi:
I compiled nginx1.4.7,add
to --with-pcre=/root/nginx/pcre-8.34 --with-http_rewrite_module parameter;An
error occurred :./configure: error: invalid option “–with-http_rewrite_module”
,Trouble who can talk about what is the problem

It’s on by default. You can switch it off with the
–without-http_rewrite_module flag.

hth,

Steve


Steve H. BSc(Hons) MIITP
http://www.greengecko.co.nz
Linkedin: http://www.linkedin.com/in/steveholdoway
Skype: sholdowa

Think you
But If I turn off the words,I have no way is to use ‘if’ order.An
error occurred : [emerg] 14499#0: unknown directive “if($remote_addr” in
/usr/local/nginx1/conf/nginx.conf:46

[email protected]

From: Steve H.
Date: 2014-05-13 13:09
To: nginx
Subject: Re: Compile nginx 1.4.7 --with-http_rewrite_module Error
On Tue, 2014-05-13 at 11:25 +0800, [email protected] wrote:

hi:
I compiled nginx1.4.7,add
to --with-pcre=/root/nginx/pcre-8.34 --with-http_rewrite_module parameter;An
error occurred :./configure: error: invalid option “–with-http_rewrite_module”
,Trouble who can talk about what is the problem

It’s on by default. You can switch it off with the
–without-http_rewrite_module flag.

hth,

Steve


Steve H. BSc(Hons) MIITP
http://www.greengecko.co.nz
Linkedin: http://www.linkedin.com/in/steveholdoway
Skype: sholdowa

ngx_http_rewrite_module
syntax:if (condition) { … }
default:—
context:server, location
I use in location’,

[email protected]

From: Valentin V. Bartenev
Date: 2014-05-13 15:15
To: nginx
Subject: Re: Compile nginx 1.4.7 --with-http_rewrite_module Error
On Tuesday 13 May 2014 13:34:11 [email protected] wrote:

Think you
But If I turn off the words,I have no way is to use ‘if’ order.An error
occurred : [emerg] 14499#0: unknown directive “if($remote_addr” in
/usr/local/nginx1/conf/nginx.conf:46
There is no directive “if($remote_addr” in nginx.

Evidently you have missed a space after the “if” directive.

wbr, Valentin V. Bartenev

Think you
The problem has been resolved.Because ‘if($remote_addr’ , ‘If’ and
‘(’ a space is required between

[email protected]

From: Valentin V. Bartenev
Date: 2014-05-13 15:15
To: nginx
Subject: Re: Compile nginx 1.4.7 --with-http_rewrite_module Error
On Tuesday 13 May 2014 13:34:11 [email protected] wrote:

Think you
But If I turn off the words,I have no way is to use ‘if’ order.An error
occurred : [emerg] 14499#0: unknown directive “if($remote_addr” in
/usr/local/nginx1/conf/nginx.conf:46
There is no directive “if($remote_addr” in nginx.

Evidently you have missed a space after the “if” directive.

wbr, Valentin V. Bartenev

On Tuesday 13 May 2014 13:34:11 [email protected] wrote:

Think you
But If I turn off the words,I have no way is to use ‘if’ order.An error
occurred : [emerg] 14499#0: unknown directive “if($remote_addr” in
/usr/local/nginx1/conf/nginx.conf:46

There is no directive “if($remote_addr” in nginx.

Evidently you have missed a space after the “if” directive.

wbr, Valentin V. Bartenev

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs