Compile error for Nginx 1.1.2

Hello all,

I am trying to install Nginx-1.1.2 on mac os x-lion,but while doing make
i am getting following error,i have searched through forums but didnt
found clear steps to resolve the error,
please help

cc1: warnings being treated as errors
src/core/ngx_crypt.c: In function ‘ngx_crypt_apr1’:
src/core/ngx_crypt.c:76: warning: ‘MD5_Init’ is deprecated (declared at
/usr/include/openssl/md5.h:113)
src/core/ngx_crypt.c:77: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:78: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:79: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:81: warning: ‘MD5_Init’ is deprecated (declared at
/usr/include/openssl/md5.h:113)
src/core/ngx_crypt.c:82: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:83: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:84: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:85: warning: ‘MD5_Final’ is deprecated (declared at
/usr/include/openssl/md5.h:115)
src/core/ngx_crypt.c:88: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:95: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:98: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:102: warning: ‘MD5_Final’ is deprecated (declared
at /usr/include/openssl/md5.h:115)
src/core/ngx_crypt.c:105: warning: ‘MD5_Init’ is deprecated (declared at
/usr/include/openssl/md5.h:113)
src/core/ngx_crypt.c:108: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:111: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:115: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:119: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:123: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:126: warning: ‘MD5_Update’ is deprecated (declared
at /usr/include/openssl/md5.h:114)
src/core/ngx_crypt.c:129: warning: ‘MD5_Final’ is deprecated (declared
at /usr/include/openssl/md5.h:115)
src/core/ngx_crypt.c: In function ‘ngx_crypt_ssha’:
src/core/ngx_crypt.c:215: warning: ‘SHA1_Init’ is deprecated (declared
at /usr/include/openssl/sha.h:121)
src/core/ngx_crypt.c:216: warning: ‘SHA1_Update’ is deprecated (declared
at /usr/include/openssl/sha.h:122)
src/core/ngx_crypt.c:217: warning: ‘SHA1_Update’ is deprecated (declared
at /usr/include/openssl/sha.h:122)
src/core/ngx_crypt.c:218: warning: ‘SHA1_Final’ is deprecated (declared
at /usr/include/openssl/sha.h:123)
make[1]: *** [objs/src/core/ngx_crypt.o] Error 1
make: *** [build] Error 2

Hello!

On Thu, Mar 01, 2012 at 02:29:45PM +0100, umesh chaudhari wrote:

/usr/include/openssl/md5.h:113)
Upgrade to nginx 1.1.16. There is a problem with openssl shipped
with Mac OS X Lion, the workaround has been added in nginx 1.1.3.

Maxim D.

Hi Maxim, thanks for the quick reply but i managed to install nginx
using brew on my mac…which solved my problem temporarily…brew has
installed nginx-1.0.11…i will keep in mind your suggestion while
installing nginx from source…thanks again…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs